Project

General

Profile

Bug #10280

Regression while evaluating default argments of a method

Added by iffyuva (Yuva Kumar) over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.2.0preview1 (2014-09-17 trunk 47616) [x86_64-darwin13]
[ruby-core:65213]

Description

class DefArg
  def calc(str, val=val)
    p val
  end

  def val
    10
  end
end

# ruby-2.2.0-preview1 => nil
# ruby-2.1.3          => 10
DefArg.new.calc("hello")

im not sure what ruby spec says. but it looks like this program should print 10 in both the cases.


Related issues

Related to Ruby trunk - Bug #10314: Default argument lookup fails in Ruby 2.2 for circular shadowed variable namesOpenActions
Is duplicate of Ruby trunk - Bug #9593: Keyword arguments default argument assignment behaviour not consistent with optional argumentClosed03/05/2014Actions

History

Updated by nobu (Nobuyoshi Nakada) over 4 years ago

  • Is duplicate of Bug #9593: Keyword arguments default argument assignment behaviour not consistent with optional argument added

Updated by nobu (Nobuyoshi Nakada) over 4 years ago

  • Description updated (diff)
  • Status changed from Open to Rejected

Updated by hsbt (Hiroshi SHIBATA) over 4 years ago

  • Related to Bug #10314: Default argument lookup fails in Ruby 2.2 for circular shadowed variable names added

Also available in: Atom PDF