Project

General

Profile

Bug #10313

Randomly build failure on Travis container.

Added by hsbt (Hiroshi SHIBATA) almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
2.2.0
[ruby-core:65355]

Description

We tested ruby trunk every commits, but it failed randomly with linux container on travis.

build log is here: https://s3.amazonaws.com/archive.travis-ci.org/jobs/36822816/log.txt

It's caused by fadvice(2). it details is following:

# make test-all
TestIO#test_advise:
Errno::EINVAL: Invalid argument - /tmp/test_io20141001-24823-10d6utc (0, 0, willneed)

# make test-rubyspec
IO#advise supports the willneed advice type ERROR
Errno::EINVAL: Invalid argument -  (0, 0, willneed)

Is there workaround this?

Updated by normalperson (Eric Wong) almost 6 years ago

shibata.hiroshi@gmail.com wrote:

We tested ruby trunk every commits, but it failed randomly with linux container on travis.

build log is here: https://s3.amazonaws.com/archive.travis-ci.org/jobs/36822816/log.txt

It's caused by fadvice(2). it details is following:

# make test-all
TestIO#test_advise:
Errno::EINVAL: Invalid argument - /tmp/test_io20141001-24823-10d6utc (0, 0, willneed)

This seems to be a problem on old Linux kernels (2.6.32 from what Travis
log says) and tmpfs.

Which Linux kernels do you hit successful builds on?
Are they using tmpfs for /tmp?

kosaki fixed it in
Linux kernel commit 3d3727cdb07ff17ddc3c551ef8d03d37b60a0372
"mm, fadvise: don't return -EINVAL when filesystem cannot implement fadvise()"
(but old kernels will be around for many more years)

Is there workaround this?

I think we need to accept EINVAL in our tests, unless there is a way
to force the test to run on a regular FS.

Updated by hsbt (Hiroshi SHIBATA) almost 6 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Applied in changeset r47771.


  • test/ruby/test_io.rb (TestIO#test_advise): added workaround of fadvise(2) with tmpfs and old linux kernel. [ruby-core:65355][Bug #10313]

Also available in: Atom PDF