Project

General

Profile

Bug #10325

[PATCH] test_string (test_LSHIFT_neary_long_max): skip if low on memory

Added by normalperson (Eric Wong) over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
trunk
[ruby-core:65410]

Description

I've been skipping this test for a while on my weaker systems,
but this makes it automated so it avoids triggering a swap storm
for Linux users less familiar with the test suite.

I think this only affects Linux which defaults to overcommit. Asking
users to disable overcommit is unreasonable, so I figure this is the
best way...


Files

Updated by nobu (Nobuyoshi Nakada) over 5 years ago

  • Status changed from Open to Assigned
  • Assignee set to normalperson (Eric Wong)

I'm not against that check, but we may enable that test only on 64bit Windows, since it is nearly impossible to reproduce on other platforms, because of memory usage.

Updated by normalperson (Eric Wong) over 5 years ago

nobu@ruby-lang.org wrote:

I'm not against that check, but we may enable that test only on 64bit
Windows, since it is nearly impossible to reproduce on other
platforms, because of memory usage.

OK, can you add the 64-bit Windows check instead?
I do not know the proper platform checks for those, there are so many.
It think *BSD folks on smaller machines may appreciate it more.
Thanks.

Updated by normalperson (Eric Wong) over 5 years ago

  • Assignee changed from normalperson (Eric Wong) to nobu (Nobuyoshi Nakada)

Updated by nobu (Nobuyoshi Nakada) over 5 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

Applied in changeset r47817.


test_string.rb: enable huge test only on possible platforms

  • test/ruby/test_string.rb (test_LSHIFT_neary_long_max): enable only on platforms where string size range is smaller than memory space. this test does not make sense but just wastes memory and time on other platforms, as it is hardly possible that a string size becomes neary LONG_MAX if long size equals pointer size. [ruby-core:65410] [Bug #10325]

Also available in: Atom PDF