Project

General

Profile

Bug #10374

FileUtils.mv can't move broken symlinks

Added by Polyergic (Shad Sterling) about 6 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.0.0p481 (2014-05-08 revision 45883) [universal.x86_64-darwin13]
[ruby-core:65634]

Description

FileUtils.mv raises Errno::ENOENT when invoked on a broken symlink, even though the symlink does exist.


Files

mvfail.rb (150 Bytes) mvfail.rb Demonstration Polyergic (Shad Sterling), 10/12/2014 11:38 PM

Related issues

Is duplicate of Ruby master - Bug #6716: FileUtils.mv でリンク先がないシンボリックリンクファイルを指定すると ENOENT エラーになるClosednobu (Nobuyoshi Nakada)07/10/2012Actions

Also available in: Atom PDF