Project

General

Profile

Actions

Bug #10408

closed

[BUG] Segmentation fault ruby 2.1.3p242 (2014-09-19 revision 47630) [i386-mingw32]

Added by golovan (Eugene G.) about 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
cruby-windows
Target version:
-
ruby -v:
ruby 2.1.3p242 (2014-09-19 revision 47630) [i386-mingw32]
[ruby-core:65824]

Description

Platform Win7 x64. Just installed. Getting this error after using next command.

C:\usr\ruby2>gem update --system && gem update && gem cleanup
Latest version currently installed. Aborting.
Updating installed gems
Updating rake
rake's executable "rake" conflicts with C:/usr/ruby2/bin/rake
Overwrite the executable? [yN]  C:/usr/ruby2/lib/ruby/site_ruby/2.1.0/rubygems/user_interaction.rb:294: [BUG] Segmentation fault
ruby 2.1.3p242 (2014-09-19 revision 47630) [i386-mingw32]

(snip)


Files

bug-10408.log (19.7 KB) bug-10408.log nobu (Nobuyoshi Nakada), 11/29/2014 11:39 PM

Related issues

Related to Ruby master - Bug #10606: Ruby on consoles emulatorsClosed12/16/2014Actions
Has duplicate Ruby master - Bug #10546: Bug Segmentation Fault when input prompt on cmderClosedcruby-windows11/26/2014Actions
Has duplicate Ruby master - Bug #10665: irb segfaults on user input (irb 0.9.6 / ruby 2.1.5p273 / i386-mingw32) under ConEmuClosed12/28/2014Actions
Has duplicate Ruby master - Bug #10832: while loop segmentation faultClosed02/06/2015Actions
Has duplicate Ruby master - Bug #11031: Segmentation Fault on Gem UninstallRejectedActions

Updated by hsbt (Hiroshi SHIBATA) about 7 years ago

I can't reproduce this with Windows 8.1. (x86-mingw32)

Updated by golovan (Eugene G.) about 7 years ago

Hey Hiroshi,

Thanks for your answer! From this log, do you have any idea what could cause that? Ruby 2.1.3 x64 gives the same error. I think I will try to install 2.0.0 now.

Updated by golovan (Eugene G.) about 7 years ago

FYI, latest rubyinstaller-2.0.0-p576.exe has no issues at all. All is fine on the same machine.

Updated by golovan (Eugene G.) almost 7 years ago

Just was notified by another developer. This is somehow related to Conemu. There is no such issue in cmd.exe.

Updated by nobu (Nobuyoshi Nakada) almost 7 years ago

  • Has duplicate Bug #10546: Bug Segmentation Fault when input prompt on cmder added

Updated by nobu (Nobuyoshi Nakada) almost 7 years ago

Updated by luislavena (Luis Lavena) almost 7 years ago

  • Related to Bug #10606: Ruby on consoles emulators added

Updated by nobu (Nobuyoshi Nakada) almost 7 years ago

  • Has duplicate Bug #10665: irb segfaults on user input (irb 0.9.6 / ruby 2.1.5p273 / i386-mingw32) under ConEmu added
Actions #9

Updated by nobu (Nobuyoshi Nakada) over 6 years ago

  • Has duplicate Bug #10832: while loop segmentation fault added
Actions #10

Updated by nobu (Nobuyoshi Nakada) over 6 years ago

  • Has duplicate Bug #11031: Segmentation Fault on Gem Uninstall added
Actions

Also available in: Atom PDF