Project

General

Profile

Bug #10626

BUS error from nesting lambda's and calls to methods defined with define_method

Added by jaroslawr (Jarosław Rzeszótko) over 5 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
2.1.5
[ruby-core:67002]

Description

I get a BUS error from executing the following Ruby program: https://gist.github.com/jaroslawr/8579678d7c68a49208f0

I am on Gentoo Linux and Ruby 2.1.5, and have also tried Ruby 2.1.4, 2.1.3, ..., down to 2.1.0. My colleagues The problem seems to lie in rapidly consuming stack space, and goes away when the stack size limit is increased with ulimit -s. For the real world context behind this, see the corresponding Rails issue I opened:

https://github.com/rails/rails/issues/18011


Related issues

Is duplicate of Ruby master - Bug #10460: Segfault instead of stack level too deepClosednobu (Nobuyoshi Nakada)Actions

Also available in: Atom PDF