Project

General

Profile

Actions

Bug #10725

closed

Segfault with ObjectSpace::trace_object_allocations_start

Added by vihai (Daniele Orlandi) over 7 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.2.0p0 (2014-12-25 revision 49005) [x86_64-linux-gnu]
[ruby-core:<unknown>]

Description

While trying to pin down a memory leak issue I enabled trace_object_allocations_start but after a while my application (a daemon, not rails) crashes. I attached the output.


Files

ruby_crash (136 KB) ruby_crash vihai (Daniele Orlandi), 01/09/2015 10:05 PM

Updated by nobu (Nobuyoshi Nakada) over 7 years ago

  • Status changed from Open to Feedback

We don't have the same environment equals to yours, we can't address where it happens without the debugging information.
And, as you use some extension libraries, especially ffi, it might be impossible to fix by us.

Updated by vihai (Daniele Orlandi) over 7 years ago

Nobuyoshi Nakada wrote:

We don't have the same environment equals to yours, we can't address where it happens without the debugging information.
And, as you use some extension libraries, especially ffi, it might be impossible to fix by us.

I understand the difficulties in handling such kind of issues.

I am not able to reproduce the issue in simpler environments but I can try to run gdb while it happens and gather some more info.

Actions #3

Updated by jeremyevans0 (Jeremy Evans) almost 3 years ago

  • Status changed from Feedback to Closed
Actions

Also available in: Atom PDF