Project

General

Profile

Bug #10970

Backport r49867

Added by yuki24 (Yuki Nishijima) over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.0.0p643 (2015-02-25 revision 49749) [x86_64-linux], ruby 2.1.5p273 (2014-11-13 revision 48405) [x86_64-linux], ruby 2.2.1p85 (2015-02-26 revision 49769) [x86_64-linux]
[ruby-core:<unknown>]

Description

Please backport r49867 to 2.0, 2.1 and 2.2 as well.


Related issues

Is duplicate of Ruby master - Bug #10847: SystemStackError after NameError prepends a moduleClosed02/12/2015Actions

Associated revisions

Revision 54dc1cf1
Added by nagachika (Tomoyuki Chikanaga) over 4 years ago

merge revision(s) 49867: [Backport #10847] [Backport #10970]

    * vm_eval.c (vm_call_super): search next super class from the
      original class, to get rid of infinite recursion with
      prepending.  a patch by Seiei Higa <hanachin AT gmail.com> at
      [ruby-core:68434].  [ruby-core:68093] [Bug #10847]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_2@50275 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 50275
Added by nagachika (Tomoyuki Chikanaga) over 4 years ago

merge revision(s) 49867: [Backport #10847] [Backport #10970]

* vm_eval.c (vm_call_super): search next super class from the
  original class, to get rid of infinite recursion with
  prepending.  a patch by Seiei Higa <hanachin AT gmail.com> at
  [ruby-core:68434].  [ruby-core:68093] [Bug #10847]

Revision 602edc0c
Added by usa (Usaku NAKAMURA) over 4 years ago

merge revision(s) 49867: [Backport #10847] [Backport #10970]

    * vm_eval.c (vm_call_super): search next super class from the
      original class, to get rid of infinite recursion with
      prepending.  a patch by Seiei Higa <hanachin AT gmail.com> at
      [ruby-core:68434].  [ruby-core:68093] [Bug #10847]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_1@50284 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 50284
Added by usa (Usaku NAKAMURA) over 4 years ago

merge revision(s) 49867: [Backport #10847] [Backport #10970]

* vm_eval.c (vm_call_super): search next super class from the
  original class, to get rid of infinite recursion with
  prepending.  a patch by Seiei Higa <hanachin AT gmail.com> at
  [ruby-core:68434].  [ruby-core:68093] [Bug #10847]

History

#1

Updated by usa (Usaku NAKAMURA) over 4 years ago

  • Is duplicate of Bug #10847: SystemStackError after NameError prepends a module added
#2

Updated by usa (Usaku NAKAMURA) over 4 years ago

  • Status changed from Open to Closed
#3

Updated by nagachika (Tomoyuki Chikanaga) over 4 years ago

  • Backport changed from 2.0.0: REQUIRED, 2.1: REQUIRED, 2.2: REQUIRED to 2.0.0: REQUIRED, 2.1: REQUIRED, 2.2: DONE

Backported into ruby_2_2 branch at r50275.

#4

Updated by usa (Usaku NAKAMURA) over 4 years ago

  • Backport changed from 2.0.0: REQUIRED, 2.1: REQUIRED, 2.2: DONE to 2.0.0: REQUIRED, 2.1: DONE, 2.2: DONE

ruby_2_1 r50284 merged revision(s) 49867.

Also available in: Atom PDF