Project

General

Profile

Bug #11089

2.2.2p95 crash on Windows when passed glob patterns on command line

Added by larsch (Lars Christensen) about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.2.2p95 (2015-04-13 revision 50295) [i386-mswin32_120]
[ruby-core:68966]

Description

Command:

mkdir foo
ruby -e "p ARGV" foo/*
ruby -e "p ARGV" foo/**
ruby -e "p ARGV" foo/**/*

Result:

Ruby 2.2.2p95 mswin32_120 build: Crash, access violation
RubyInstaller 2.2.2p95: Exit without any output

Related issues

Is duplicate of Ruby master - Bug #10941: SIGSEGV caused by Rake on WindowsClosedActions
#1

Updated by nobu (Nobuyoshi Nakada) about 5 years ago

  • Is duplicate of Bug #10941: SIGSEGV caused by Rake on Windows added

Updated by nobu (Nobuyoshi Nakada) about 5 years ago

  • Description updated (diff)
  • Status changed from Open to Closed
  • Backport changed from 2.0.0: UNKNOWN, 2.1: UNKNOWN, 2.2: UNKNOWN to 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: REQUIRED
#3

Updated by nagachika (Tomoyuki Chikanaga) about 5 years ago

  • Backport changed from 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: REQUIRED to 2.0.0: DONTNEED, 2.1: DONTNEED, 2.2: DONE

fixes are backported into ruby_2_2 branch at r50545 for #10941.

Also available in: Atom PDF