Project

General

Profile

Bug #11176

Hardcoded settings in REXML

Added by tomasbedrich (Tomáš Bedřich) almost 4 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-core:69346]

Description

XMLDecl has hardcoded single qoutes (see here: https://bugs.ruby-lang.org/projects/ruby-trunk/repository/entry/lib/rexml/xmldecl.rb#L109). So it is impossible to set document-wide double quoting.


Related issues

Is duplicate of Ruby trunk - Bug #9367: REXML::XmlDecl doesn't use user specified quotesClosedActions

History

Updated by nobu (Nobuyoshi Nakada) almost 4 years ago

  • Status changed from Open to Assigned
  • Assignee set to kou (Kouhei Sutou)

Why is it a problem?

#2

Updated by duerst (Martin Dürst) almost 4 years ago

  • Is duplicate of Bug #9367: REXML::XmlDecl doesn't use user specified quotes added
#3

Updated by kou (Kouhei Sutou) 3 months ago

  • Status changed from Assigned to Closed

I've implemented :prologue_quote context option. Available values are :quote and :apostrophe.

https://github.com/ruby/rexml/commit/e89702294881a8aedb15905d8a85137876749f7f

Also available in: Atom PDF