Feature #1136

"ri Kernel#require" is broken

Added by Jeremy Henty about 5 years ago. Updated almost 3 years ago.

[ruby-core:21954]
Status:Closed
Priority:Normal
Assignee:Eric Hodel
Category:lib
Target version:1.9.3

Description

=begin
$ ri Kernel#require
More than one method matched your request. You can refine
your search by asking for information on one of:

  Kernel#require, Kernel#rescue_require, Kernel#require

Now what do I do to see the Kernel#require documentation?
=end

History

#1 Updated by Kornelius Kalnbach about 5 years ago

=begin
Jeremy Henty wrote:

Bug #1136: "ri Kernel#require" is broken
http://redmine.ruby-lang.org/issues/show/1136

Author: Jeremy Henty
Status: Open, Priority: Normal
ruby -v: ruby 1.8.7 (2008-08-11 patchlevel 72) [i686-linux]

$ ri Kernel#require
More than one method matched your request. You can refine
your search by asking for information on one of:

 Kernel#require, Kernel#rescue_require, Kernel#require

Now what do I do to see the Kernel#require documentation?
it would be nice if ri would use a ambiguity resolution like gem:

$ gem uninstall rails
Select gem to uninstall:
1. rails-1.2.6
2. rails-2.1.2
3. rails-2.2.2
4. All versions

4

like
$ ri Kernel#require
More than one method matched your request. Which one did you mean?
1. Kernel#require
2. Kernel#rescue_require
3. Kernel#require

1

[murphy]

=end

#2 Updated by Akira Tanaka almost 3 years ago

  • Project changed from Ruby to ruby-trunk
  • Assignee set to Eric Hodel

#3 Updated by Eric Hodel almost 3 years ago

  • Category set to lib
  • Status changed from Open to Closed
  • Target version set to 1.9.3

I cannot reproduce:

$ gem19 install rails -i ~/tmp/gems

24 gems installed
$ GEM_HOME=~/tmp/gems ri19 Kernel#require

Kernel#require

(from ruby core)

$ GEMHOME=~/tmp/gems ri19 --version
ri19 3.8
$ ruby19 --version
ruby 1.9.3dev (2011-07-07 trunk 32428) [x86
64-darwin10.8.0]

Also available in: Atom PDF