Project

General

Profile

Bug #11691

Permission denied @ rb_sysopen did_you_mean-1.0.0.beta3.gemspec

Added by sawa (Tsuyoshi Sawada) over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
ruby 2.3.0preview1 (2015-11-11 trunk 52539) [x86_64-linux]
[ruby-core:71496]

Description

When I ruby Ruby, I get this error:

/usr/local/lib/ruby/2.3.0/rubygems/stub_specification.rb:80:in `initialize': Permission denied @ rb_sysopen - /usr/local/lib/ruby/gems/2.3.0/specifications/did_you_mean-1.0.0.beta3.gemspec (Errno::EACCES)
    from /usr/local/lib/ruby/2.3.0/rubygems/stub_specification.rb:80:in `open'
    from /usr/local/lib/ruby/2.3.0/rubygems/stub_specification.rb:80:in `data'
    from /usr/local/lib/ruby/2.3.0/rubygems/stub_specification.rb:186:in `valid?'
    from /usr/local/lib/ruby/2.3.0/rubygems/specification.rb:749:in `select'
    from /usr/local/lib/ruby/2.3.0/rubygems/specification.rb:749:in `gemspec_stubs_in'
    from /usr/local/lib/ruby/2.3.0/rubygems/specification.rb:755:in `block in map_stubs'
    from /usr/local/lib/ruby/2.3.0/rubygems/specification.rb:755:in `each'
    from /usr/local/lib/ruby/2.3.0/rubygems/specification.rb:755:in `flat_map'
    from /usr/local/lib/ruby/2.3.0/rubygems/specification.rb:755:in `map_stubs'
    from /usr/local/lib/ruby/2.3.0/rubygems/specification.rb:806:in `stubs'
    from /usr/local/lib/ruby/2.3.0/rubygems/specification.rb:1009:in `find_by_path'
    from /usr/local/lib/ruby/2.3.0/rubygems.rb:188:in `try_activate'
    from /usr/local/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:126:in `rescue in require'
    from /usr/local/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb:39:in `require'
    from <internal:gem_prelude>:4:in `<compiled>'


Related issues

Is duplicate of Ruby trunk - Bug #11685: rbinstall does not set Gem specification permission correctlyClosedActions

History

#1

Updated by usa (Usaku NAKAMURA) over 3 years ago

  • Is duplicate of Bug #11685: rbinstall does not set Gem specification permission correctly added

Updated by hsbt (Hiroshi SHIBATA) over 3 years ago

  • Assignee set to hsbt (Hiroshi SHIBATA)
#3

Updated by hsbt (Hiroshi SHIBATA) over 3 years ago

  • Status changed from Open to Closed

Applied in changeset r52585.


  • tool/rbinstall.rb: fix wrong permission for gem specification without zlib runtime. [Bug #11685][ruby-dev:49343]

Also available in: Atom PDF