Project

General

Profile

Bug #11805

Cannot run Ruby

Added by sawa (Tsuyoshi Sawada) almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.3.0preview2 (2015-12-11 trunk 53028) [x86_64-linux]
[ruby-core:72056]

Description

I installed the new Ruby, and tried to run Ruby, but it raises the following error.

(Since I installed Ruby 2.3.0preview1, it had a bug, and I had not been able to run Ruby, and now, after having waited for a month, I installed the new one, and there still is a bug. Disappointed a little bit.)

/usr/local/lib/ruby/site_ruby/2.3.0/rubygems/stub_specification.rb:112:in `initialize': Permission denied @ rb_sysopen - /usr/local/lib/ruby/gems/2.3.0/specifications/did_you_mean-1.0.0.beta3.gemspec (Errno::EACCES)
from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/stub_specification.rb:112:in `open'
from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/stub_specification.rb:112:in `data'
from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/stub_specification.rb:203:in `valid?'
from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/specification.rb:748:in `select'
from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/specification.rb:748:in `gemspec_stubs_in'
from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/specification.rb:773:in `block in map_stubs'
from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/specification.rb:770:in `each'
from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/specification.rb:770:in `flat_map'
from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/specification.rb:770:in `map_stubs'
from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/specification.rb:762:in `installed_stubs'
from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/specification.rb:830:in `stubs'
from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/specification.rb:1035:in `find_by_path'
from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems.rb:188:in `try_activate'
from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:124:in `rescue in require'
from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:39:in `require'
from <internal:gem_prelude>:6:in `<internal:gem_prelude>'

History

Updated by hsbt (Hiroshi SHIBATA) almost 4 years ago

  • Status changed from Open to Feedback

Can you try with clean install with Ruby 2.3.0 preview2?

It's caused by overwrite install probably.

Updated by sawa (Tsuyoshi Sawada) almost 4 years ago

I figured out how to fix it.

I manually deleted the following directories on Ubuntu linux that were created when I installed Ruby 2.3.0 preview 1:

/usr/local/lib/ruby/2.3.0
/usr/local/lib/ruby/gems/2.3.0
/usr/local/lib/ruby/site_ruby/2.3.0
/usr/local/lib/ruby/vendor_ruby/2.3.0

Then, following the suggestion, I deleted the directory

ruby-2.3.0-preview2

which was messed up by previous ./configure and make. Then reinstalled, and it worked.

Updated by yugui (Yuki Sonoda) almost 4 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF