Project

General

Profile

Bug #12149

Backport r51930 (test_s_open_lock hangs on AIX)

Added by ReiOdaira (Rei Odaira) about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:74199]

Description

This is a ticket to back-port r51930 to 2.1 and 2.2 (not to 2.3).

Associated revisions

Revision 09298fae
Added by usa (Usaku NAKAMURA) about 3 years ago

merge revision(s) 51930: [Backport #12149]

* test/gdbm/test_gdbm.rb (TestGDBM#test_s_open_lock): skip
  this test on AIX. The issue is the same as on Solaris.
  [ruby-dev:47631]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_1@54265 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 54265
Added by usa (Usaku NAKAMURA) about 3 years ago

merge revision(s) 51930: [Backport #12149]

* test/gdbm/test_gdbm.rb (TestGDBM#test_s_open_lock): skip
  this test on AIX. The issue is the same as on Solaris.
  [ruby-dev:47631]

Revision 77fa4641
Added by nagachika (Tomoyuki Chikanaga) about 3 years ago

merge revision(s) 51930: [Backport #12149]

* test/gdbm/test_gdbm.rb (TestGDBM#test_s_open_lock): skip
  this test on AIX. The issue is the same as on Solaris.
  [ruby-dev:47631]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_2@54324 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 54324
Added by nagachika (Tomoyuki Chikanaga) about 3 years ago

merge revision(s) 51930: [Backport #12149]

* test/gdbm/test_gdbm.rb (TestGDBM#test_s_open_lock): skip
  this test on AIX. The issue is the same as on Solaris.
  [ruby-dev:47631]

History

Updated by usa (Usaku NAKAMURA) about 3 years ago

  • Backport changed from 2.1: REQUIRED, 2.2: REQUIRED, 2.3: DONTNEED to 2.1: DONE, 2.2: REQUIRED, 2.3: DONTNEED

ruby_2_1 r54265 merged revision(s) 51930.

Updated by nagachika (Tomoyuki Chikanaga) about 3 years ago

  • Backport changed from 2.1: DONE, 2.2: REQUIRED, 2.3: DONTNEED to 2.1: DONE, 2.2: DONE, 2.3: DONTNEED

Backported into ruby_2_2 branch at r54324.

Also available in: Atom PDF