Project

General

Profile

Bug #12153

Backport r54003 (nextafter(3) on AIX is broken with +0.0 and -0.0 arguments)

Added by ReiOdaira (Rei Odaira) about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:74206]

Description

This is a ticket to back-port r54003 to 2.2 and 2.3.

Associated revisions

Revision 1f4640cf
Added by nagachika (Tomoyuki Chikanaga) about 3 years ago

merge revision(s) 54003: [Backport #12153]

* test/-ext-/float/test_nextafter.rb: In AIX,
  nextafter(+0.0,-0.0)=+0.0, and nextafter(-0.0,+0.0)=-0.0,
  but they should return -0.0 and +0.0, respectively. This is
  a known bug in nextafter(3) on AIX, so skip related tests.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_2@54338 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 54338
Added by nagachika (Tomoyuki Chikanaga) about 3 years ago

merge revision(s) 54003: [Backport #12153]

* test/-ext-/float/test_nextafter.rb: In AIX,
  nextafter(+0.0,-0.0)=+0.0, and nextafter(-0.0,+0.0)=-0.0,
  but they should return -0.0 and +0.0, respectively. This is
  a known bug in nextafter(3) on AIX, so skip related tests.

Revision c03f28c9
Added by naruse (Yui NARUSE) about 3 years ago

merge revision(s) 54003: [Backport #12153]

* test/-ext-/float/test_nextafter.rb: In AIX,
  nextafter(+0.0,-0.0)=+0.0, and nextafter(-0.0,+0.0)=-0.0,
  but they should return -0.0 and +0.0, respectively. This is
  a known bug in nextafter(3) on AIX, so skip related tests.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_3@54385 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 54385
Added by naruse (Yui NARUSE) about 3 years ago

merge revision(s) 54003: [Backport #12153]

* test/-ext-/float/test_nextafter.rb: In AIX,
  nextafter(+0.0,-0.0)=+0.0, and nextafter(-0.0,+0.0)=-0.0,
  but they should return -0.0 and +0.0, respectively. This is
  a known bug in nextafter(3) on AIX, so skip related tests.

History

Updated by nagachika (Tomoyuki Chikanaga) about 3 years ago

  • Backport changed from 2.1: DONTNEED, 2.2: REQUIRED, 2.3: REQUIRED to 2.1: DONTNEED, 2.2: DONE, 2.3: REQUIRED

Backported into ruby_2_2 branch at r54338.

Updated by naruse (Yui NARUSE) about 3 years ago

  • Backport changed from 2.1: DONTNEED, 2.2: DONE, 2.3: REQUIRED to 2.1: DONTNEED, 2.2: DONE, 2.3: DONE

ruby_2_3 r54385 merged revision(s) 54003.

Also available in: Atom PDF