Project

General

Profile

Actions

Bug #12171

closed

TestFile#test_file_share_delete failure

Added by moritat (Tsuyoshi Morita) over 8 years ago. Updated about 8 years ago.

Status:
Closed
Assignee:
-
Target version:
-
ruby -v:
ruby 2.3.0p0 (2015-12-25 revision 53290) [i386-mingw32]
[ruby-core:74285]

Description

I got an failure in Mingw-w64 32bit.

1) Failure:
TestFile#test_file_share_delete [E:/Jenkins/jobs/RubyInstaller32_ruby23_4.7.2/workspace/sandbox/ruby_2_3/test/ruby/test_file.rb:418]:
Exception raised:
<#<Errno::EACCES: Permission denied @ unlink_internal - c:/temp/test_file_share_delete20160211-11728-1qcjzrd/x>>.

The cause is from O_SHARE_DELETE definition.

  include/ruby/win32.h:130:#define O_SHARE_DELETE 0x80000000 /* for rb_w32_open(), rb_w32_wopen() */
  file.c:6044:    rb_define_const(rb_mFConst, "SHARE_DELETE", INT2FIX(O_SHARE_DELETE));

In 32bit machine, 0x80000000 is out of Fixnum range.


Related issues 1 (0 open1 closed)

Related to Ruby master - Bug #12193: ruby 2.3 on windows test-all failedClosedActions
Actions #1

Updated by nobu (Nobuyoshi Nakada) over 8 years ago

  • Status changed from Open to Closed

Applied in changeset r54094.


win32.h: fix O_SHARE_DELETE

Actions #2

Updated by nobu (Nobuyoshi Nakada) about 8 years ago

  • Related to Bug #12193: ruby 2.3 on windows test-all failed added
Actions #3

Updated by naruse (Yui NARUSE) about 8 years ago

  • Backport changed from 2.1: DONTNEED, 2.2: DONTNEED, 2.3: REQUIRED to 2.1: DONTNEED, 2.2: DONTNEED, 2.3: DONE

ruby_2_3 r54412 merged revision(s) 54094.

Actions

Also available in: Atom PDF

Like0
Like0Like0Like0