Project

General

Profile

Bug #12309

Segmentation fault caused by OpenSSL

Added by jhaig (Joseph Haig) over 4 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.3.0p0 (2015-12-25 revision 53290) [x86_64-linux]
[ruby-core:75115]

Description

I am consistently getting a segmentation fault whils running Sinatra. It appears to be during an net/http request to an ssl endpoint on a remote web server. The full stack trace is below.

Sinatra runs correctly for a few minutes, making numerous requests with net/http, but then fails with the segmentation fault. I can find nothing particularly unusual with either the offending request or its response.

I am using an up-to-date version of Ubuntu 14.04 LTS.

$ ruby -ropenssl -e 'p OpenSSL::OPENSSL_VERSION'
"OpenSSL 1.0.1f 6 Jan 2014"

Files

bug-12309.log (82.6 KB) bug-12309.log nobu (Nobuyoshi Nakada), 04/22/2016 01:57 PM

Related issues

Related to Ruby master - Bug #12292: Race between OpenSSL::SSL::SSLSocket#stop and #connect can cause a segmentation faultClosedrhenium (Kazuki Yamaguchi)Actions

Updated by nobu (Nobuyoshi Nakada) over 4 years ago

Maybe [Bug #12126]?

#2

Updated by naruse (Yui NARUSE) about 4 years ago

  • Related to Bug #12126: [PATCH] openssl: accept moving write buffer for write_nonblock added
#3

Updated by naruse (Yui NARUSE) about 4 years ago

  • Related to Bug #6168: Segfault in OpenSSL bindings added
#4

Updated by rhenium (Kazuki Yamaguchi) almost 4 years ago

  • Related to deleted (Bug #6168: Segfault in OpenSSL bindings)

Updated by rhenium (Kazuki Yamaguchi) almost 4 years ago

  • Status changed from Open to Rejected

It looks like the same issue as [Bug #12292] rather than [Bug #12126], because #12126 should not be a cause of a segfault. (and net/http does not use SSLSocket#write_nonblock, does it?)

Please provide a reproducer if it is a different issue.

#6

Updated by rhenium (Kazuki Yamaguchi) almost 4 years ago

  • Related to deleted (Bug #12126: [PATCH] openssl: accept moving write buffer for write_nonblock)
#7

Updated by rhenium (Kazuki Yamaguchi) almost 4 years ago

  • Related to Bug #12292: Race between OpenSSL::SSL::SSLSocket#stop and #connect can cause a segmentation fault added

Also available in: Atom PDF