Project

General

Profile

Bug #13422

etc.gemspec is invalid (typo)

Added by stomar (Marcus Stollsteimer) about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-core:80656]

Description

The gemspec for etc is invalid (and lets rvm install ruby-head fail):

diff --git a/ext/etc/etc.gemspec b/ext/etc/etc.gemspec
index fd81ec3..f961b67 100644
--- a/ext/etc/etc.gemspec
+++ b/ext/etc/etc.gemspec
@@ -3,7 +3,7 @@
 Gem::Specification.new do |spec|
   spec.name          = "etc"
   spec.version       = "0.2.1"
-  soec.date          = '2017-02-27'
+  spec.date          = '2017-02-27'
   spec.authors       = ["Yukihiro Matsumoto"]
   spec.email         = ["matz@ruby-lang.org"]

I wanted to open an issue on GitHub, but the affected line doesn't exist in the gemspec there.

On a side note: will spec.files with git ls-files ... work in all installation scenarios?

History

Updated by vo.x (Vit Ondruch) about 2 years ago

  • Status changed from Open to Closed

This was resolved by trunk|r58316

Updated by vo.x (Vit Ondruch) about 2 years ago

stomar (Marcus Stollsteimer) wrote:

On a side note: will spec.files with git ls-files ... work in all installation scenarios?

Not sure what is the plan, but it the end result were "bundled_gems" approach, the this would be ok.

Updated by stomar (Marcus Stollsteimer) about 2 years ago

I see... I guess it would work for release tarballs; but e.g. not for make install in a subversion working copy of the source.

Anyway, in the meantime there was opened a separate ticket for this, see #13423.

Also available in: Atom PDF