Project

General

Profile

Backport #1383

ruby segfaults on redhat el3 amd64

Added by ittayd (Ittay Dror) over 10 years ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-

Description

=begin
ruby constantly segfaults. below is part of the stack as shown by gdb. i'd be happy to provide more information if you tell me what you need. unfortunately, i can't provide the code that caused this nor a toy example to recreate.

#0 rb_eval (self=184139294640, n=0x2a96e4b360) at eval.c:2945
#1 0x000000000041490b in rb_eval (self=184139294640, n=0x2a96e4b360) at eval.c:3488
#2 0x000000000041348a in rb_eval (self=184139294640, n=0x2a96e4b360) at eval.c:3049
#3 0x0000000000413b13 in rb_eval (self=184139294640, n=0x2a96e4b360) at eval.c:3183
#4 0x0000000000419da4 in rb_call0 (klass=182920164920, recv=184139294640, id=3439, oid=0, argc=0, argv=0x7fbfe04290, body=0x2a96e4b0e0, flags=0)
at eval.c:6057
#5 0x000000000041a54f in rb_call (klass=182920164920, recv=184139294640, mid=3439, argc=1, argv=0x7fbfe04288, scope=0, self=184139294320) at eval.c:6153
#6 0x0000000000414a11 in rb_eval (self=184139294320, n=0x2a96e4b360) at eval.c:3496
#7 0x000000000041348a in rb_eval (self=184139294320, n=0x2a96e4b360) at eval.c:3049
#8 0x0000000000419da4 in rb_call0 (klass=182920164920, recv=184139294320, id=2961, oid=0, argc=0, argv=0x7fbfe08190, body=0x2a96e4c008, flags=2)
at eval.c:6057
#9 0x000000000041a54f in rb_call (klass=182920164920, recv=184139294320, mid=2961, argc=3, argv=0x7fbfe08178, scope=1, self=6) at eval.c:6153
#10 0x000000000041ab54 in rb_funcall2 (recv=184139294640, mid=182920196960, argc=-1075840816, argv=0x0) at ruby.h:696
#11 0x000000000041d884 in rb_obj_call_init (obj=184139294320, argc=3, argv=0x7fbfe08178) at eval.c:7789
#12 0x0000000000443b31 in rb_class_new_instance (argc=3, argv=0x7fbfe08178, klass=184139294640) at object.c:1644
#13 0x00000000004275e6 in call_cfunc (func=0x443b00 , recv=182920164920, len=-1075840816, argc=-544299088, argv=0x2a96e4b360)
at eval.c:5751
#14 0x0000000000419a34 in rb_call0 (klass=182904302080, recv=182920164920, id=3361, oid=4294967295, argc=3, argv=0x7fbfe08178, body=0x2a95f204f8, flags=0)
at eval.c:5906
#15 0x000000000041a54f in rb_call (klass=182904302080, recv=182920164920, mid=3361, argc=3, argv=0x7fbfe08178, scope=0, self=184139294640) at eval.c:6153
#16 0x0000000000414a11 in rb_eval (self=184139294640, n=0x2a96e4b360) at eval.c:3496
#17 0x0000000000419da4 in rb_call0 (klass=182920164920, recv=184139294640, id=20985, oid=0, argc=0, argv=0x7fbfe0a0b0, body=0x2a96e4ab68, flags=0)
at eval.c:6057
#18 0x000000000041a54f in rb_call (klass=182920164920, recv=184139294640, mid=20985, argc=1, argv=0x7fbfe0a0a8, scope=0, self=184139954480) at eval.c:6153
#19 0x0000000000414a11 in rb_eval (self=184139954480, n=0x2a96e4b360) at eval.c:3496
#20 0x0000000000414ccb in rb_eval (self=184139954480, n=0x2a96e4b360) at ruby.h:701
#21 0x0000000000415473 in rb_eval (self=184139954480, n=0x2a96e4b360) at eval.c:3278
#22 0x000000000041490b in rb_eval (self=184139954480, n=0x2a96e4b360) at eval.c:3488
#23 0x0000000000419da4 in rb_call0 (klass=182920165120, recv=184139954480, id=49185, oid=0, argc=0, argv=0x7fbfe10ca8, body=0x2a96e447e0, flags=0)
at eval.c:6057
#24 0x000000000041a54f in rb_call (klass=182920165120, recv=184139954480, mid=49185, argc=2, argv=0x7fbfe10c98, scope=1, self=184139954480) at eval.c:6153
#25 0x0000000000414a11 in rb_eval (self=184139954480, n=0x2a96e4b360) at eval.c:3496
#26 0x000000000041632e in rb_eval (self=184139954480, n=0x2a96e4b360) at eval.c:3438
#27 0x0000000000419da4 in rb_call0 (klass=182920165120, recv=184139954480, id=49185, oid=0, argc=0, argv=0x7fbfe14568, body=0x2a96e447e0, flags=0)
at eval.c:6057
#28 0x000000000041a54f in rb_call (klass=182920165120, recv=184139954480, mid=49185, argc=2, argv=0x7fbfe14558, scope=1, self=184139954480) at eval.c:6153
#29 0x0000000000414a11 in rb_eval (self=184139954480, n=0x2a96e4b360) at eval.c:3496
#30 0x0000000000415473 in rb_eval (self=184139954480, n=0x2a96e4b360) at eval.c:3278
#31 0x000000000041490b in rb_eval (self=184139954480, n=0x2a96e4b360) at eval.c:3488
#32 0x0000000000419da4 in rb_call0 (klass=182920165120, recv=184139954480, id=49185, oid=0, argc=0, argv=0x7fbfe197b8, body=0x2a96e447e0, flags=0)
at eval.c:6057
=end

Associated revisions

Revision 52666
Added by hsbt (Hiroshi SHIBATA) almost 4 years ago

  • lib/rubygems: Update to RubyGems 2.5.0+ HEAD(c6b4946). this version includes #1114, #1314, #1322, #1375, #1383, #1387
  • test/rubygems: ditto.

Revision 52666
Added by hsbt (Hiroshi SHIBATA) almost 4 years ago

  • lib/rubygems: Update to RubyGems 2.5.0+ HEAD(c6b4946). this version includes #1114, #1314, #1322, #1375, #1383, #1387
  • test/rubygems: ditto.

Revision 52666
Added by hsbt (Hiroshi SHIBATA) almost 4 years ago

  • lib/rubygems: Update to RubyGems 2.5.0+ HEAD(c6b4946). this version includes #1114, #1314, #1322, #1375, #1383, #1387
  • test/rubygems: ditto.

Revision 52666
Added by hsbt (Hiroshi SHIBATA) almost 4 years ago

  • lib/rubygems: Update to RubyGems 2.5.0+ HEAD(c6b4946). this version includes #1114, #1314, #1322, #1375, #1383, #1387
  • test/rubygems: ditto.

Revision 52666
Added by hsbt (Hiroshi SHIBATA) almost 4 years ago

  • lib/rubygems: Update to RubyGems 2.5.0+ HEAD(c6b4946). this version includes #1114, #1314, #1322, #1375, #1383, #1387
  • test/rubygems: ditto.

History

#1

Updated by naruse (Yui NARUSE) about 10 years ago

  • Status changed from Open to Feedback
  • Priority changed from 6 to Normal

=begin
We can't reproduce this because we doesn't have RHEL3 with AMD64.
Anyone has more information about this?
=end

#2

Updated by jeremyevans0 (Jeremy Evans) 4 months ago

  • ruby -v deleted (ruby 1.8.7 (2009-04-08 patchlevel 160) [x86_64-linux])
  • Status changed from Feedback to Closed
  • Description updated (diff)
  • Project changed from Ruby 1.8 to Backport187
  • Tracker changed from Bug to Backport

Also available in: Atom PDF