Project

General

Profile

Bug #13891

Rake - no files in bin folder - 59839

Added by MSP-Greg (Greg L) 14 days ago. Updated 14 days ago.

Status:
Open
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.5.0dev (2017-09-11 trunk 59839) [x64-mingw32]
[ruby-core:82752]

Description

I just noticed that my most recent build has no rake files in the bin folder. It does have bundle & rdoc files, which, unlike rake, are default gems. No other bundled gems have files located in bin.

I checked builds every few days going back to 01Aug, and all of them have the files, the last being 59828. All of those builds used rake 12.0.0...

Anyone else having this issue?

History

#1 [ruby-core:82754] Updated by MSP-Greg (Greg L) 14 days ago

I should have checked more thoroughly.

In the 'install package' lib/ruby/gems/2.5.0 folder, the cache and specification folders are always loaded correctly, but the actual gems folder is not. It has a directory for each bundled gem, but some gems appear partially installed, others are empty.

I double checked, and I am placing the files (unpacked gems and *.gem) in the source gems directory to match the locations that would occur with the tarballs.

#2 [ruby-core:82755] Updated by shevegen (Robert A. Heiler) 14 days ago

I think it is all a bit messy right now and a while ago. :)

See also other errors related to gems and compiling them, then them being in the wrong directory.

I double checked, and I am placing the files (unpacked gems and *.gem) in the source gems directory to
match the locations that would occur with the tarballs.

X-mas release is still some months away so hopefully things will have resolved up until that point (and also hopefully cleaned up before bundler is merged but I understand that things take time there).

I think I reported a similar issue not long ago, and the ruby-core team pointed to some slightly older reports so I think the situation is known - I guess it really is just a question when it will be resolved, not "if". :)

Also available in: Atom PDF