Project

General

Profile

Actions

Bug #13900

closed

Segmentation fault - 2 different machines

Added by marmotteNZ (pierre lonchampt) almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.3.1p112 (2016-04-26) [x86_64-linux-gnu]
[ruby-core:82804]

Description

The same error appears systematically - on two different installs of Ruby 2.3.1
A/ Ubuntu 16.04 in Windows10 WSL
B/ Bodhi 4.3.1 on a virtualBOx Windows 10 host.

I followed the message at the end inviting me to report a bug. Hope it helps

BAcktrace:

peter@peter-VirtualBox:/media/sf_Dropbox_(Sonomat)/ENG/Code/Ruby$ ruby listSpectro.rb

listSpectro.rb:35: [BUG] Segmentation fault at 0x0000000000001c
(snip)
Aborted
peter@peter-VirtualBox:/media/sf_Dropbox_(Sonomat)/ENG/Code/Ruby$

Files

bug-13900.log (26 KB) bug-13900.log nobu (Nobuyoshi Nakada), 09/15/2017 04:54 AM

Related issues 1 (0 open1 closed)

Is duplicate of Ruby master - Bug #12670: Segmentation fault on `Magick::Image#get_pixels` on ruby since ruby-2.2Closedko1 (Koichi Sasada)Actions
Actions #1

Updated by nobu (Nobuyoshi Nakada) almost 5 years ago

  • Is duplicate of Bug #12670: Segmentation fault on `Magick::Image#get_pixels` on ruby since ruby-2.2 added
Actions #2

Updated by nobu (Nobuyoshi Nakada) almost 5 years ago

Updated by naruse (Yui NARUSE) almost 5 years ago

  • Status changed from Open to Closed

As nobu wrote, this issue is already fixed.
You can avoid this by upgrading Ruby to 2.3.5 or 2.4.2.

Actions

Also available in: Atom PDF