Project

General

Profile

Bug #13911

Breaking 2.5.0 Installation with in-place build.

Added by hsbt (Hiroshi SHIBATA) almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-dev:50250]

Description

9/17 時点の trunk HEAD である r59936 を用いて、ソースコードと同じディレクトリで make して make install すると旧 ruby-runner がインストールされるようです。

https://gist.github.com/hsbt/aa69c38fe05947cce6487a6f6e42d4ed

r59927 で入れた bin/ruby へのリネームによって、旧 ruby-runner が bin/ruby としてインストールされてしまうようです。

ソースコードのディレクトリとは別の working ディレクトリでビルド、インストールした場合は発生しません。

Associated revisions

Revision 30290144
Added by nobu (Nobuyoshi Nakada) almost 2 years ago

Rename bin/ruby as exe/ruby

  • common.mk, configure.in: rename the bin directory to run build executable as exe, to get rid of overwriting true files at the installation. [ruby-dev:50250] [Bug #13911]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@59937 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 59937
Added by nobu (Nobuyoshi Nakada) almost 2 years ago

Rename bin/ruby as exe/ruby

  • common.mk, configure.in: rename the bin directory to run build executable as exe, to get rid of overwriting true files at the installation. [ruby-dev:50250] [Bug #13911]

Revision 59937
Added by nobu (Nobuyoshi Nakada) almost 2 years ago

Rename bin/ruby as exe/ruby

  • common.mk, configure.in: rename the bin directory to run build executable as exe, to get rid of overwriting true files at the installation. [ruby-dev:50250] [Bug #13911]

Revision 59937
Added by nobu (Nobuyoshi Nakada) almost 2 years ago

Rename bin/ruby as exe/ruby

  • common.mk, configure.in: rename the bin directory to run build executable as exe, to get rid of overwriting true files at the installation. [ruby-dev:50250] [Bug #13911]

Revision 9bad616b
Added by sonots (Naotoshi Seo) almost 2 years ago

  • .gitignore: ignore exe/ruby and exe/.time instead of bin/ruby because bin/ruby was renamed as exe/ruby at r59937.

follow-up: [Bug #13911]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@60166 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 60166
Added by sonots (Naotoshi Seo) almost 2 years ago

  • .gitignore: ignore exe/ruby and exe/.time instead of bin/ruby because bin/ruby was renamed as exe/ruby at r59937.

follow-up: [Bug #13911]

Revision 60166
Added by sonots (Naotoshi Seo) almost 2 years ago

  • .gitignore: ignore exe/ruby and exe/.time instead of bin/ruby because bin/ruby was renamed as exe/ruby at r59937.

follow-up: [Bug #13911]

Revision 60166
Added by sonots (Naotoshi Seo) almost 2 years ago

  • .gitignore: ignore exe/ruby and exe/.time instead of bin/ruby because bin/ruby was renamed as exe/ruby at r59937.

follow-up: [Bug #13911]

History

#1

Updated by nobu (Nobuyoshi Nakada) almost 2 years ago

  • Status changed from Open to Closed

Applied in changeset trunk|r59937.


Rename bin/ruby as exe/ruby

  • common.mk, configure.in: rename the bin directory to run build executable as exe, to get rid of overwriting true files at the installation. [ruby-dev:50250] [Bug #13911]

Updated by hsbt (Hiroshi SHIBATA) almost 2 years ago

  • Backport changed from 2.2: UNKNOWN, 2.3: UNKNOWN, 2.4: UNKNOWN to 2.2: DONTNEED, 2.3: DONTNEED, 2.4: DONTNEED

I confirmed to fix this issue at r59937

Also available in: Atom PDF