Project

General

Profile

Bug #13990

Remove obsoleted Ruby code from lib/rdoc/ruby_token.rb from 2.3 and 2.4

Added by sho-h (Sho Hashimoto) almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Target version:
-
[ruby-core:83180]

Description

Symbol document at docs.ruby-lang.org/en is broken.

The reason is RDoc::RubyToken::Symbol in lib/rdoc/ruby_token.rb was aliased to ::Integer.

lib/rdoc/ruby_token.rb was deleted from rdoc 6.0.0. So, trunk will be fixed later.

but 2.3 and 2.4 need fix this problem.

see below.


Files

remove_obsolete_ruby_code.patch (424 Bytes) remove_obsolete_ruby_code.patch sho-h (Sho Hashimoto), 10/09/2017 02:46 AM

Associated revisions

Revision db6c51ec
Added by hsbt (Hiroshi SHIBATA) almost 2 years ago

Merge rdoc-6.0.0.beta3.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@60146 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 60146
Added by hsbt (Hiroshi SHIBATA) almost 2 years ago

Merge rdoc-6.0.0.beta3.

Revision 60146
Added by hsbt (Hiroshi SHIBATA) almost 2 years ago

Merge rdoc-6.0.0.beta3.

Revision 60146
Added by hsbt (Hiroshi SHIBATA) almost 2 years ago

Merge rdoc-6.0.0.beta3.

History

Updated by hsbt (Hiroshi SHIBATA) almost 2 years ago

  • Assignee set to hsbt (Hiroshi SHIBATA)
  • Status changed from Open to Assigned
#2

Updated by hsbt (Hiroshi SHIBATA) almost 2 years ago

  • Status changed from Assigned to Closed

Applied in changeset trunk|r60146.


Merge rdoc-6.0.0.beta3.

Updated by hsbt (Hiroshi SHIBATA) almost 2 years ago

to usa, nagachika.

Please bump up rdoc version with sho-h's patch.

  • Ruby 2.3: 4.2.1 to 4.2.1.1
  • Ruby 2.4: 5.0.0 to 5.0.0.1

Updated by sho-h (Sho Hashimoto) over 1 year ago

This ticket was closed but 2.3 and 2.4 is not fixed yet.

hsbt (Hiroshi SHIBATA): Should I reopen this ticket?

Updated by usa (Usaku NAKAMURA) over 1 year ago

Do not reopen it.
Status "Closed" and Backport "REQUIRED" are the signal for backporting.

Also available in: Atom PDF