Project

General

Profile

Actions

Bug #1404

closed

Net::HTTP::Post failing when a post field contains ":"

Added by imar (Ignacio Martín) over 12 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
ruby 1.9.0 (2007-12-25 revision 14709) [i486-linux]
Backport:
[ruby-core:23311]

Description

=begin
require 'net/http'

post_me = {
'var' => 'a:b'
}
uri = URI.parse(")
request = Net::HTTP::Post.new(uri.path)
request.set_form_data(post_me)


Gives the following error:

/usr/lib/ruby/1.9.0/net/http.rb:1524:in sprintf': invalid value for Integer: ":" (ArgumentError)
from /usr/lib/ruby/1.9.0/net/http.rb:1524:in
block in urlencode'
from /usr/lib/ruby/1.9.0/net/http.rb:1524:in gsub'
from /usr/lib/ruby/1.9.0/net/http.rb:1524:in
urlencode'
from /usr/lib/ruby/1.9.0/net/http.rb:1519:in block in encode_kvpair'
from /usr/lib/ruby/1.9.0/net/http.rb:1519:in
map'
from /usr/lib/ruby/1.9.0/net/http.rb:1519:in encode_kvpair'
from /usr/lib/ruby/1.9.0/net/http.rb:1512:in
block in set_form_data'
from /usr/lib/ruby/1.9.0/net/http.rb:1512:in each'
from /usr/lib/ruby/1.9.0/net/http.rb:1512:in
map'
from /usr/lib/ruby/1.9.0/net/http.rb:1512:in set_form_data'
from rubybug.rb:7:in
'
=end

Actions #1

Updated by nobu (Nobuyoshi Nakada) over 12 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

=begin
Applied in changeset r23277.
=end

Actions #2

Updated by nobu (Nobuyoshi Nakada) over 12 years ago

  • Status changed from Closed to Open

=begin

=end

Actions #3

Updated by nobu (Nobuyoshi Nakada) over 12 years ago

=begin
Hi,

At Sat, 25 Apr 2009 18:51:50 +0900,
daz wrote in [ruby-core:23313]:

^ (?) Change seems to be for:
http://redmine.ruby-lang.org/issues/show/1403 (not 1404?)

Just For Your Information: Wrong bug closed ? :)

Sorry, wrong ML ref.

--
Nobu Nakada

=end

Actions #4

Updated by nobu (Nobuyoshi Nakada) over 12 years ago

=begin
Hi,

At Sat, 25 Apr 2009 15:06:51 +0900,
Ignacio Martín wrote in [ruby-core:23311]:

Bug #1404: Net::HTTP::Post failing when a post field contains ":"
http://redmine.ruby-lang.org/issues/show/1404

I can't reproduce the problem with 1.9.1p0.

Author: Ignacio Martín
Status: Open, Priority: Normal
Category: core, Target version: 1.9.0-5
ruby -v: ruby 1.9.0 (2007-12-25 revision 14709) [i486-linux]

Why don't you update it?

--
Nobu Nakada

=end

Actions #5

Updated by nobu (Nobuyoshi Nakada) over 12 years ago

  • Status changed from Open to Feedback

=begin

=end

Actions #6

Updated by marcandre (Marc-Andre Lafortune) about 12 years ago

  • Status changed from Feedback to Closed

=begin

=end

Actions

Also available in: Atom PDF