Project

General

Profile

Bug #14117

[Compile] config.sub missing in 2.5.0-preview1 pulled from GitHub

Added by leam (Leam Hall) about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
2.5.0-preview1
[ruby-core:83829]

Description

Updated autoconf to GNU latest (2.69). In "ruby" ran "autoconf".
When running ./configure I get:
configure: error: cannot run /bin/sh tool/config.sub

Checking tools/, there is no "config.sub".
Copying in the config.sub from 2.4.2 source seems to work so far.

History

#1

Updated by leam (Leam Hall) about 2 years ago

  • Subject changed from [Compile] config.sub missing in 2.5.0-preview1 to [Compile] config.sub missing in 2.5.0-preview1 pulled from GitHub

This issue occurs if you clone the github repo. It does not happen if you download the tar.gz file.

When running ./configure I get:
configure: error: cannot run /bin/sh tool/config.sub

Checking tools/, there is no "config.sub".
Copying in the config.sub from 2.4.2 source seems to work so far.

Updated by MSP-Greg (Greg L) about 2 years ago

When using the repo, you need:

make update-config_files

If you have any more build questions, the .travis.yml file and the travis logs may be helpful (and also with gems, etc).

Updated by leam (Leam Hall) about 2 years ago

Greg, that works!

Of course, make update-config_files looks for an existing Ruby as well, which seems a different issue. Not sure how it would do a totally clean build.

Now I just have to figure out how to close the issue....

#4

Updated by Eregon (Benoit Daloze) about 2 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF