Project

General

Profile

Bug #14163

Pages of rdoc include files which are not documents

Added by znz (Kazuhiro NISHIYAMA) about 2 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
trunk
[ruby-core:84141]

Description

https://docs.ruby-lang.org/en/trunk/ includes *.tt, *.gemspec, Executable, Executable.bundler, Executable.standalone.
But it seems there are not documents nor sources including documents.


Related issues

Related to Ruby master - Bug #15531: Ignore gemspec files for rdoc.ClosedActions

Associated revisions

Revision ef839356
Added by hsbt (Hiroshi SHIBATA) about 2 years ago

Ignore to generate documentation for template files of bundler.

[Bug #14163][ruby-core:84141]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@61104 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 61104
Added by hsbt (Hiroshi SHIBATA) about 2 years ago

Ignore to generate documentation for template files of bundler.

[Bug #14163][ruby-core:84141]

Revision 61104
Added by hsbt (Hiroshi SHIBATA) about 2 years ago

Ignore to generate documentation for template files of bundler.

[Bug #14163][ruby-core:84141]

Revision 61104
Added by hsbt (Hiroshi SHIBATA) about 2 years ago

Ignore to generate documentation for template files of bundler.

[Bug #14163][ruby-core:84141]

History

#1

Updated by hsbt (Hiroshi SHIBATA) about 2 years ago

  • Status changed from Open to Closed

Applied in changeset trunk|r61104.


Ignore to generate documentation for template files of bundler.

[Bug #14163][ruby-core:84141]

Updated by hsbt (Hiroshi SHIBATA) about 2 years ago

  • Backport changed from 2.3: UNKNOWN, 2.4: UNKNOWN to 2.3: DONTNEED, 2.4: DONTNEED
  • Assignee set to hsbt (Hiroshi SHIBATA)

Updated by znz (Kazuhiro NISHIYAMA) almost 2 years ago

  • Status changed from Closed to Assigned

*.gemspec are still there.

Updated by hsbt (Hiroshi SHIBATA) almost 2 years ago

  • Status changed from Assigned to Closed

I ignored them at r61140

Updated by zverok (Victor Shepelev) 11 months ago

  • Status changed from Closed to Open

And here they are again: https://docs.ruby-lang.org/en/2.6.0/ (seems the problem is related to new default gems?)

Updated by hsbt (Hiroshi SHIBATA) 11 months ago

  • Status changed from Open to Closed

Do not reuse the existence issue and modify status by yourself without maintainers. Because We use status is backport workflow for stable versions.

Please open another issue.

#7

Updated by hsbt (Hiroshi SHIBATA) 11 months ago

  • Related to Bug #15531: Ignore gemspec files for rdoc. added

Also available in: Atom PDF