Project

General

Profile

Bug #14448

Build Failure - MinGW gcc 7.3.0 ~ svn 62220 - RUBY_CHECK_VA_COPY

Added by MSP-Greg (Greg L) 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.6.0dev (2018-02-05 trunk 62224) [x64-mingw32]
[ruby-core:85395]

Description

Seem to be having build failures with MinGW / gcc 7.3.0. Log shown below:

==> Starting build()...
ruby 2.6.0dev 2018-02-05 62230
configure: loading site script /etc/config.site
../ruby/configure: line 15109: syntax error near unexpected token `va_copy,'
../ruby/configure: line 15109: `      RUBY_CHECK_VA_COPY(va_copy, va_copy((dst),(src)))'
==> ERROR: A failure occurred in build().
    Aborting...
Command exited with code 1
if "%TEST_SCRIPT%" NEQ "done

Thanks, Greg

Associated revisions

Revision 62243
Added by shyouhei (Shyouhei Urabe) 5 months ago

deal with aclocal(1)

This commit updates files so that aclocal.m4 generated by aclocal(1)
works well with our configure.ac

* ac_checking.m4: merged back to configure.ac because
  aclocal(1) cannot handle this macro.

* ruby_append_options.m4: no longer used.

* ruby_check_va_copy.m4: define using AC_DEFUN so that
  aclocal(1) can find this macro.

History

#1 Updated by MSP-Greg (Greg L) 5 months ago

  • ruby -v changed from ruby 2.6.0dev (2018-02-05 trunk 62230) [x64-mingw32] to ruby 2.6.0dev (2018-02-05 trunk 62224) [x64-mingw32]
  • Subject changed from Build Failure - MinGW gcc 7.3.0 ~ svn 62224 forward RUBY_CHECK_VA_COPY to Build Failure - MinGW gcc 7.3.0 ~ svn 62224 forward - RUBY_CHECK_VA_COPY

#2 [ruby-core:85406] Updated by k0kubun (Takashi Kokubun) 5 months ago

  • Status changed from Open to Feedback

Hmm, I couldn't reproduce this with r62237, aclocal v1.51.1, autoconf v2.69, gcc 7.2.0 on MinGW.
Does this happen even if you build from clean build directory? And doesn't this happen with r62223?

#3 [ruby-core:85407] Updated by MSP-Greg (Greg L) 5 months ago

ruby-loco is built three times a day on Appveyor.

See https://ci.appveyor.com/project/MSP-Greg/ruby-loco/history. A list of Appveyor packages is at https://ci.appveyor.com/project/MSP-Greg/appveyor-ruby, but the build does update some of them.

So, first, the build directory is clean, and secondly, I don't know which commit caused the failure.

I haven't done any local builds yet, so I don't know exactly which commit/svn is causing the issue, but looking thru them earlier it seemed clear.

Lastly, builds have been successful with MSYS2 gcc 7.3.0 since it's release.

Thanks, Greg

#4 [ruby-core:85412] Updated by MSP-Greg (Greg L) 5 months ago

  • Subject changed from Build Failure - MinGW gcc 7.3.0 ~ svn 62224 forward - RUBY_CHECK_VA_COPY to Build Failure - MinGW gcc 7.3.0 ~ svn 62220 - RUBY_CHECK_VA_COPY

k0kubun (Takashi Kokubun)

Ran some local builds. The problem is 62220, build script error is as above:

ruby 2.6.0dev 2018-02-05 62220
configure: loading site script /etc/config.site
../ruby/configure: line 15109: syntax error near unexpected token `va_copy,'
../ruby/configure: line 15109: `      RUBY_CHECK_VA_COPY(va_copy, va_copy((dst),(src)))'

I haven't stopped it yet, but 62219 is building away...

Thanks for your help,

Greg

#5 [ruby-core:85423] Updated by shyouhei (Shyouhei Urabe) 5 months ago

RUBY_CHECK_VA_COPY is me. However it's strange because I cannot reproduce. Is it possible for you to show us your build script?

#6 [ruby-core:85425] Updated by MSP-Greg (Greg L) 5 months ago

shyouhei (Shyouhei Urabe),

Given that I'm not really a c type, please have a look. It's at:

https://github.com/MSP-Greg/ruby-loco/blob/master/PKGBUILD

I can attached it if that would be helpful. The last 'real' commit to the script was in October, and there's been three builds a day, so it has been reliable...

Thanks for your work,

Greg

#7 [ruby-core:85426] Updated by MSP-Greg (Greg L) 5 months ago

shyouhei (Shyouhei Urabe),

You did use the term 'show'. The code (in total) generates all the logs and the Appveyor built title and messages. It also applies a lot of patches, mostly to the test system. The 'PKGBUILD' file is just the prepare/build/install script, with ruby scripts called before and after, and also within...

If you go to https://ci.appveyor.com/project/MSP-Greg/ruby-loco/build/417/artifacts, you can download the 'zlogs_trunk_2018-02-05_62216.7z' file and see what's output.

I need to redo the patch system, as originally I hoped that a simple 'less than' / 'greater than' version constraint would work. I've now determined that an interval system is required, and haven't decided how far to go with it. Reason being is that when questions come up as to backporting, I'd prefer to just checkout a commit locally and have it build & test. Especially if I was building back when the commit occurred. FYI, I've got all the builds saved locally, going back to early April.

Thanks,

Greg

Said simply,

#8 [ruby-core:85427] Updated by shyouhei (Shyouhei Urabe) 5 months ago

Thank you. It seems the problem is autoreconf. I guess it clobbers aclocal.m4 file.
Hang on, I think I can fix it.

#9 [ruby-core:85428] Updated by MSP-Greg (Greg L) 5 months ago

shyouhei (Shyouhei Urabe),

Not sure if you're referring to fixing it in ruby/ruby or ruby-loco PKGBUILD. Feel free to make suggestions as to the build script. For someone who doesn't know c, I did the best I could, given that MinGW isn't mswin, but it's not really *nix...

Greg

#10 [ruby-core:85430] Updated by shyouhei (Shyouhei Urabe) 5 months ago

@MSP-Greg

I think I fixed this in r62243. Can you try?

#11 [ruby-core:85433] Updated by MSP-Greg (Greg L) 5 months ago

Shyouhei,

Thank you. Started a local build, and it's gotten past where it failed before. The next Appveyor build runs at Noon JST (~30 minutes from now?)...

Again, thanks for the help. I hate posting about things I can't fix, but better now than a week, a month, etc...

Greg

#12 [ruby-core:85434] Updated by shyouhei (Shyouhei Urabe) 5 months ago

  • Status changed from Feedback to Closed

Closed. Thank you for the report!

Also available in: Atom PDF