Project

General

Profile

Bug #14544

crash on gem update

Added by allank (Allan Kinnaird) over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.5.0p0 (2017-12-25 revision 61468) [x86_64-darwin17]
[ruby-core:85770]

Description

After a clean install using rbenv on a new MacBook Pro running High Sierra 10.13.3, gem update fails:
~: gem update
Updating installed gems
Updating ffi
Fetching: ffi-1.9.22.gem (100%)
Building native extensions. This could take a while...
Successfully installed ffi-1.9.22
Parsing documentation for ffi-1.9.22
Installing ri documentation for ffi-1.9.22
Installing darkfish documentation for ffi-1.9.22
/usr/local/var/rbenv/versions/2.5.0/lib/ruby/2.5.0/rdoc/markup/to_html.rb:389: [BUG] Segmentation fault at 0x0000000000000020
ruby 2.5.0p0 (2017-12-25 revision 61468) [x86_64-darwin17]


Files

ruby_2018-02-23-094545_Allans-MacBook-Pro.crash (44.4 KB) ruby_2018-02-23-094545_Allans-MacBook-Pro.crash Crash log allank (Allan Kinnaird), 02/23/2018 10:41 AM

Related issues

Is duplicate of Ruby master - Bug #14261: invalid syntax segfaults: "x, true"ClosedActions
Has duplicate Ruby master - Bug #14554: gem update crashes ClosedActions

History

#1

Updated by vo.x (Vit Ondruch) over 1 year ago

  • Is duplicate of Bug #14261: invalid syntax segfaults: "x, true" added

Updated by vo.x (Vit Ondruch) over 1 year ago

This is the same as #14343, but the real solution is #14261

#3

Updated by vo.x (Vit Ondruch) over 1 year ago

  • Status changed from Open to Closed
#4

Updated by nobu (Nobuyoshi Nakada) over 1 year ago

  • Has duplicate Bug #14554: gem update crashes added

Also available in: Atom PDF