Project

General

Profile

Bug #14554

gem update crashes

Added by waag_job (Waag Job) about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.5.0p0 (2017-12-25 revision 61468) [x86_64-darwin17]
[ruby-core:85827]

Description

upon running:

$ gem update

I receive a crash. Logfile plus CLI output is attached.


Files

ruby_2018-02-26-184143_.crash (44.7 KB) ruby_2018-02-26-184143_.crash Crash report waag_job (Waag Job), 02/26/2018 06:09 PM
ruby_2018-02-26-CLI-output.txt (43.8 KB) ruby_2018-02-26-CLI-output.txt output in shell waag_job (Waag Job), 02/26/2018 06:09 PM

Related issues

Is duplicate of Ruby trunk - Bug #14544: crash on gem updateClosedActions
Is duplicate of Ruby trunk - Bug #14261: invalid syntax segfaults: "x, true"ClosedActions

History

Updated by shevegen (Robert A. Heiler) about 1 year ago

/usr/local/Cellar/ruby/2.5.0_2/lib/ruby/2.5.0/rdoc/markup/to_html.rb:389: [BUG] Segmentation fault at 0x0000000000000020

I am not completely sure but I think I saw this error before. Can't recall where; probably another issue reported.

#2

Updated by nobu (Nobuyoshi Nakada) about 1 year ago

  • Is duplicate of Bug #14544: crash on gem update added
#3

Updated by nobu (Nobuyoshi Nakada) about 1 year ago

  • Is duplicate of Bug #14261: invalid syntax segfaults: "x, true" added
#4

Updated by nobu (Nobuyoshi Nakada) about 1 year ago

  • Status changed from Open to Closed

Also available in: Atom PDF