Project

General

Profile

Bug #1508

Recursive arrays with the same structure are not eql?.

Added by yugui (Yuki Sonoda) about 11 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
ruby 1.9.2dev (2009-05-24 trunk 23554) [i386-darwin9.7.0]
Backport:
[ruby-dev:38537]

Description

=begin
a = []
a << a

としたとき、 a と [a] は同じ構造を持っているのでeql?です。一方、a と a は同じ構造にもかかわらず eql? ではありません。
=end


Related issues

Is duplicate of Ruby master - Bug #1448: [patch] Proper handling of recursive arraysClosed05/09/2009Actions
#1

Updated by ujihisa (Tatsuhiro Ujihisa) about 11 years ago

=begin
本問題は http://redmine.ruby-lang.org/issues/show/1448 の部分問題です。

ただ、#1448の例が誤っているのか、

x = []; x << x
y = x
x == y # ==> true
y == x # ==> false, should be true!
の比較の結果が逆になってします。

パッチが与えられているものの、まだ適用はされていないみたいです。
=end

#2

Updated by matz (Yukihiro Matsumoto) about 11 years ago

  • Status changed from Open to Closed

=begin
#1448はなかださんによって適用されました。本件もcloseです
=end

Also available in: Atom PDF