Project

General

Profile

Bug #1577

testFileUtils failure in windows

Added by rogerdpack (Roger Pack) almost 11 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
TRUNK mingw
Backport:
[ruby-core:23724]

Description

=begin
23) Failure:
test_copy_stream(TestFileUtils)
[c:/dev/downloads/ruby_trunk/test/fileutils/test_fileutils.rb:934]:
file data/a != tmp/a.
Expected block to return true value.

This might be caused by the fact that windows doesn't write files out immediately [even if you call flush or close on them] -- you have to apparently call fsync on them first. I guess.
-=r
=end

#1

Updated by yugui (Yuki Sonoda) almost 11 years ago

  • Assignee set to nobu (Nobuyoshi Nakada)
  • Target version set to 1.9.2

=begin

=end

#2

Updated by nobu (Nobuyoshi Nakada) about 10 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

=begin
This issue was solved with changeset r27614.
Roger, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.

=end

Also available in: Atom PDF