Project

General

Profile

Actions

Bug #16033

closed

test_callinfo_unreachable_path Bus Error on Solaris sparc

Added by Kulikjak (Jakub Kulik) about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.5.5p157 (2019-03-15 revision 67260) [sparcv9-solaris2.11]
[ruby-core:94095]

Description

We recently updated to Ruby version 2.5.5 and one test on sparc started to fail:

TestRubyOptimization#test_callinfo_unreachable_path [/.../ruby-25/ruby-2.5.5/test/ruby/test_optimization.rb:707]:
pid 6104 killed by SIGABRT (signal 6) (core dumped)
| -:9: [BUG] Bus Error at 0x000000010057b324
| ruby 2.5.5p157 (2019-03-15 revision 67260) [sparcv9-solaris2.11]

Whole test result is attached (there were also three more test failures, but those are not important here).

This is happening on sparc only (we also build the same thing for intel) and was not present in our previous version 2.5.3. Also it does not appear in Ruby 2.6.0 or 2.6.3.


Files

test-results.txt (27 KB) test-results.txt Kulikjak (Jakub Kulik), 08/01/2019 01:55 PM
ruby-stack.txt (1.4 KB) ruby-stack.txt Kulikjak (Jakub Kulik), 08/01/2019 01:58 PM

Related issues 1 (0 open1 closed)

Is duplicate of Ruby master - Bug #14689: bootsnap gets object index out of range: 266287972352 (IndexError) since r63113ClosedActions
Actions #1

Updated by Kulikjak (Jakub Kulik) about 3 years ago

  • Description updated (diff)

Updated by Kulikjak (Jakub Kulik) about 3 years ago

I am also attaching some basic info from dumped core file.

IF more info is needed, I am happy to provide it.

Actions #3

Updated by nobu (Nobuyoshi Nakada) about 3 years ago

  • Is duplicate of Bug #14689: bootsnap gets object index out of range: 266287972352 (IndexError) since r63113 added
Actions #4

Updated by jeremyevans0 (Jeremy Evans) almost 3 years ago

  • Status changed from Open to Closed
Actions

Also available in: Atom PDF