Project

General

Profile

Bug #1764

rdoc for JSON comes out garbled in Ruby 1.9.1

Added by Tichy (Björn Günzel) about 10 years ago. Updated about 8 years ago.

Status:
Rejected
Priority:
Normal
ruby -v:
ruby 1.9.1p129 (2009-05-12 revision 23412) [i386-darwin9]
[ruby-core:24270]

Description

=begin
I have tried this with the source snapshot of Ruby 1.9.1 from today (which includes the updated ext/.document file)

Running rdoc on ext and lib results in generated documentation where the JSON documenation is garbled (not formatted - it shows the "#" and doesn't have linebreaks).

Running "rdoc ext/json/lib/json.rb" produces correctly formatted output (I think) for JSON. So I suppose some of the other files interfere with the doc generation.
=end

History

#1

Updated by Tichy (Björn Günzel) about 10 years ago

=begin
Here is a copy of the first couple of lines of the garbled JSON documentation:

# ---

call-seq: source()

Returns a copy of the current _source_ string, that was used to construct
this Parser.
# ---

# = json - JSON for Ruby # # == Description # # This is a implementation of the JSON specification
=end

#2

Updated by mame (Yusuke Endoh) over 9 years ago

  • Status changed from Open to Feedback
  • Assignee set to drbrain (Eric Hodel)

=begin
Hi,

Running rdoc on ext and lib results in generated documentation where the JSON documenation is garbled

Sorry, I can't understand what you say, maybe because I'm not
familiar with rdoc. Eric, do you understand the issue?

Let us know:

  • What did you do? (Just checkout and make?)
  • What did you look?
  • What did you expect?

--
Yusuke Endoh mame@tsg.ne.jp
=end

#3

Updated by drbrain (Eric Hodel) about 9 years ago

  • Category set to lib
  • Priority changed from Normal to 3

=begin
I cannot reproduce this, If I run:

rm -r .ext/rdoc; ./miniruby -I./lib -I.ext/common -I./- -r./ext/purelib.rb ./tool/runruby.rb --extout=.ext -- "./bin/rdoc" --no-force-update --all --op ".ext/rdoc" ext/json

The documentation appears to be fine.
=end

#4

Updated by drbrain (Eric Hodel) about 9 years ago

=begin
I should mention, I was using:

ruby 1.9.3dev (2010-05-26 trunk 28016) [x86_64-darwin10.3.0]
=end

#5

Updated by naruse (Yui NARUSE) about 9 years ago

  • Status changed from Feedback to Rejected

=begin

=end

Also available in: Atom PDF