Project

General

Profile

Actions

Feature #17750

closed

Update Unicode data to Unicode Version 13.0.0

Added by duerst (Martin Dürst) 6 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Target version:
[ruby-core:103033]

Description

The newest version of Unicode is Unicode 13.0.0 since about one year (see http://www.unicode.org/versions/Unicode13.0.0/). We should finally update Ruby to use Unicode 13.0.0, and probably also backport the result to Ruby 3.0. This issue serves as the main issue for this update; if necessary, I'll create sub-issues.

Currently, I don't expect any major issues (stuff that would require rewriting code) for this upgrade, but I'll check again carefully.

One problem I know of is that Unicode changed the structure of their directories somewhat. This may affect the Ruby makefile infrastructure.


Related issues

Related to Ruby master - Feature #14802: Update Unicode data to Unicode Version 11.0.0Closedduerst (Martin Dürst)Actions
Related to Ruby master - Bug #18028: test/ruby/enc/test_emoji_breaks.rb does not deal with Unicode ranges in file emoji-sequences.txtClosedduerst (Martin Dürst)Actions
Related to Ruby master - Bug #18027: test/ruby/enc/test_emoji_breaks.rb does not use the file emoji-variation-sequences.txtClosedduerst (Martin Dürst)Actions
Related to Ruby master - Feature #18029: Update Unicode Emoji version to 13.1Closedduerst (Martin Dürst)Actions
Related to Ruby master - Feature #18037: Update Unicode data to Unicode Version 14.0.0Openduerst (Martin Dürst)Actions
Blocked by Ruby master - Bug #18022: Spec errors for rbconfig/unicode_[emoji_]version_spec: Using Ruby 2.7 even when on Ruby 3.1ClosedEregon (Benoit Daloze)Actions
Actions

Also available in: Atom PDF