Project

General

Profile

Actions

Bug #18188

closed

-1 ** 0 is 1 not -1

Added by r.burrowes@auckland.ac.nz (Robert Burrowes) 4 months ago. Updated 4 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 3.0.2p107 (2021-07-07 revision 0db68f0233) [x86_64-freebsd11.2]
[ruby-core:105387]

Description

Any negative number to the power of 0 is 1, but ruby is returning -1.

i.e. it should be n == 0 ? 1 : x ** n

/usr/local/ruby3.0/bin/ruby
puts -1**0
-1


Related issues

Is duplicate of Ruby master - Bug #13152: Numeric parsing differences between ruby <-> crystalRejectedActions
Is duplicate of Ruby master - Bug #16677: Negative integer powered (**) to a float number results in a complex Closedmatz (Yukihiro Matsumoto)Actions

Updated by jeremyevans0 (Jeremy Evans) 4 months ago

  • Status changed from Open to Rejected

-1**0 is parsed as -(1**0), not (-1)**0. (-1)**0 returns 1

Actions #2

Updated by shyouhei (Shyouhei Urabe) 4 months ago

  • Is duplicate of Bug #16677: Negative integer powered (**) to a float number results in a complex added
  • Is duplicate of Bug #13152: Numeric parsing differences between ruby <-> crystal added
Actions

Also available in: Atom PDF