Project

General

Profile

Bug #2426

ruby.h fails requireing ruby/config.h

Added by dominik.elsbroek (Dominik Elsbroek) almost 10 years ago. Updated over 8 years ago.

Status:
Rejected
Priority:
Normal
ruby -v:
ruby 1.9.1p243 (2009-07-16 revision 24175) [i686-linux]
[ruby-core:27012]

Description

=begin
ruby tries to require ruby/config.h in /usr/lib/ruby/1.9.1/i686-linux/ruby.h. this fails as config.log shows. the ruby.h file is fetch by rbconfig.rb using CONFIG["rubyhdrdir"]. if i create the link to config.h in /usr/lib/ruby/1.9.1/i686-linux/ by typing ln -sf ../i686-linux/ruby/config.h config.h in /usr/include/ruby-1.9.1/ruby then everything is fine.

this is on arch linux in latest stable version.

any further information needed?
=end


Files

config.log (435 KB) config.log config.log from libprelude compile dominik.elsbroek (Dominik Elsbroek), 12/03/2009 09:35 PM

History

#1

Updated by ujihisa (Tatsuhiro Ujihisa) almost 10 years ago

  • Status changed from Open to Assigned
  • Assignee set to nobu (Nobuyoshi Nakada)

=begin

=end

#2

Updated by mame (Yusuke Endoh) over 9 years ago

=begin
Hi,

2009/12/3 Dominik Elsbroek redmine@ruby-lang.org:

ruby tries to require ruby/config.h in /usr/lib/ruby/1.9.1/i686-linux/ruby.h.

Nobu, do you think is it guaranteed to include ruby.h directly?
I think mkmf.rb must be used for the purpose. If you agree,
please close this ticket.

--
Yusuke ENDOH mame@tsg.ne.jp
=end

#3

Updated by nobu (Nobuyoshi Nakada) over 9 years ago

  • Status changed from Assigned to Feedback

=begin
Seems the installation is wrong.
1.9 doesn't put header files under libdir.
How did you install it?
=end

#4

Updated by nobu (Nobuyoshi Nakada) over 9 years ago

  • Status changed from Feedback to Rejected

=begin
No response, No problem.
=end

Also available in: Atom PDF