Project

General

Profile

Backport #2532

Backport r26052 into ruby_1_9_1 branch

Added by raorn (Alexey Froloff) over 9 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-core:27329]

Description

=begin
$ ruby -e 'p "foo".center(7, "qq")'
"foo"
$ ruby -v

ruby 1.9.1p376 (2009-12-07) [i586-linux-gnu]
=end


Related issues

Is duplicate of Backport191 - Backport #2463: String#centerClosed12/08/2009Actions
Has duplicate Backport191 - Backport #2705: rjust, ljust, and center don't behave properly in ruby 1.9.1p376 with utf-8 padstringClosed02/02/2010Actions

History

#1

Updated by naruse (Yui NARUSE) over 9 years ago

  • Status changed from Open to Closed
#2

Updated by raorn (Alexey Froloff) over 9 years ago

=begin
I am aware that this bug has been fixed in trunk. This fix should be backported to "current stable" branch, since latest recommended stable version contains this bug.
=end

#3

Updated by naruse (Yui NARUSE) over 9 years ago

=begin
#2463 is now in the tracker of 1.9.1.
=end

Also available in: Atom PDF