Project

General

Profile

Backport #2705

rjust, ljust, and center don't behave properly in ruby 1.9.1p376 with utf-8 padstring

Added by Manfred (Manfred Stienstra) about 9 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
[ruby-core:28005]

Description

=begin
The following happens on p376

'1'.rjust(3, 'é') #=> "é1"
'1'.ljust(3, 'é') #=> "1é"
'1'.center(3, 'é') #=> "1é"

On p243, 1.8.7 and 1.9.2 trunk this seems to work properly:

"éé1"
"1éé"
"é1é"
=end


Related issues

Is duplicate of Backport191 - Backport #2532: Backport r26052 into ruby_1_9_1 branchClosed12/27/2009Actions
Is duplicate of Backport191 - Backport #2463: String#centerClosed12/08/2009Actions

History

#1

Updated by nobu (Nobuyoshi Nakada) about 9 years ago

  • Category set to core
  • Assignee set to yugui (Yuki Sonoda)

=begin
r26052
=end

#2

Updated by yugui (Yuki Sonoda) about 9 years ago

  • Status changed from Open to Closed

=begin

=end

Also available in: Atom PDF