Project

General

Profile

Actions

Backport #2779

closed

Net::HTTP#get raises NoMethodError

Added by sdsykes (Stephen Sykes) over 12 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-core:28296]

Description

=begin
I think this was introduced in Revision 25851:

require 'net/http'
nh = Net::HTTP.new("does_not_exist_at_all.com")
nh.get("/")
NoMethodError: undefined method closed?' for nil:NilClass from /usr/local/lib/ruby/1.8/net/http.rb:1060:in request'
from /usr/local/lib/ruby/1.8/net/http.rb:772:in `get'
from (irb):11
from /usr/local/lib/ruby/1.8/net/http.rb:2042
=end


Related issues 2 (0 open2 closed)

Is duplicate of Backport187 - Backport #2758: NoMethodError instead of Errno::ECONNREFUSED when Net::HTTP cannot connectClosed02/19/2010Actions
Is duplicate of Backport187 - Backport #2708: NoMethodError exception generated when using net/httpClosedshyouhei (Shyouhei Urabe)02/03/2010Actions
Actions #1

Updated by shyouhei (Shyouhei Urabe) over 12 years ago

  • Status changed from Open to Closed

=begin
This issue was solved with changeset r27955.
John, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.

=end

Actions

Also available in: Atom PDF