Bug #3015

NetBSD vs test/dl

Added by Michael Graff about 5 years ago. Updated about 4 years ago.

[ruby-core:29019]
Status:Closed
Priority:Low
Assignee:Aaron Patterson
ruby -v:ruby 1.9.2dev (2010-03-26 trunk 27055) [i386-netbsdelf5.0.] Backport:

Description

=begin
There are probably related problems with the mentioned tests, or the code they are testing, on NetBSD 5.0.2.

I have not yet investigated the cause of these.

1) Error:
test_to_ptr_io(DL::TestCPtr):
RangeError: bignum too big to convert into long'
/u1/home/explorer/proj/ruby/test/dl/test_cptr.rb:84:in
call'
/u1/home/explorer/proj/ruby/test/dl/test_cptr.rb:84:in block in test_to_ptr_io'
/u1/home/explorer/proj/ruby/test/dl/test_cptr.rb:81:in
open'
/u1/home/explorer/proj/ruby/test/dl/test_cptr.rb:81:in `test_to_ptr_io'

2) Error:
test_callback(DL::TestDL):
RangeError: bignum too big to convert into long'
/u1/home/explorer/proj/ruby/test/dl/test_dl2.rb:143:in
call'
/u1/home/explorer/proj/ruby/test/dl/test_dl2.rb:143:in `test_callback'

3) Error:
test_strcpy(DL::TestDL):
RangeError: bignum too big to convert into long'
/u1/home/explorer/proj/ruby/test/dl/test_dl2.rb:134:in
call'
/u1/home/explorer/proj/ruby/test/dl/test_dl2.rb:134:in `test_strcpy'

4) Error:
test_static_sym(DL::TestHandle):
DL::DLError: unknown symbol "dlopen"
/u1/home/explorer/proj/ruby/test/dl/test_handle.rb:26:in sym'
/u1/home/explorer/proj/ruby/test/dl/test_handle.rb:26:in
test_static_sym'
=end

History

#1 Updated by Aaron Patterson about 5 years ago

  • Category set to ext
  • Assignee set to Aaron Patterson
  • Target version set to 1.9.2

=begin

=end

#2 Updated by Michael Graff about 5 years ago

=begin
On 3/25/10 8:22 PM, Aaron Patterson wrote:

Most likely this will be fixed when I get the dl/ffi underpinnings
merged to trunk. In the mean time, could you try against my ruby fork
that has ffi integrated?

https://github.com/tenderlove/ruby/tree/ffi

Certainly! I do not know what ffi is, or how it will help me, but I
will shortly :)

Cloning now.

--Michael

=end

#3 Updated by Michael Graff about 5 years ago

=begin
On 3/25/10 8:22 PM, Aaron Patterson wrote:

Most likely this will be fixed when I get the dl/ffi underpinnings
merged to trunk. In the mean time, could you try against my ruby fork
that has ffi integrated?

Trying that gives a different set of errors mostly:

1) Error:
test_to_ptr_io(DL::TestCPtr):
RangeError: bignum too big to convert into long'
/u1/home/explorer/proj/ruby-ffi/ruby/test/dl/test_cptr.rb:84:in
call'
/u1/home/explorer/proj/ruby-ffi/ruby/test/dl/test_cptr.rb:84:in
block in test_to_ptr_io'
/u1/home/explorer/proj/ruby-ffi/ruby/test/dl/test_cptr.rb:81:in
open'
/u1/home/explorer/proj/ruby-ffi/ruby/test/dl/test_cptr.rb:81:in
`test_to_ptr_io'

2) Error:
test_NEXT(DL::TestHandle):
DL::DLError: unknown symbol "malloc"
/u1/home/explorer/proj/ruby-ffi/ruby/test/dl/test_handle.rb:128:in []'
/u1/home/explorer/proj/ruby-ffi/ruby/test/dl/test_handle.rb:128:in
test_NEXT'

3) Error:
test_static_sym(DL::TestHandle):
DL::DLError: unknown symbol "dlopen"
/u1/home/explorer/proj/ruby-ffi/ruby/test/dl/test_handle.rb:25:in sym'
/u1/home/explorer/proj/ruby-ffi/ruby/test/dl/test_handle.rb:25:in
test_static_sym'

I'm willing to give out a NetBSD account to you if that helps :)

--Michael

=end

#4 Updated by Michael Graff about 5 years ago

=begin
On 3/26/10 8:16 AM, Aaron Patterson wrote:

Are you on 32bit or 64bit? I'll try installing a virtual machine.

That machine is i386, so 32-bit. I have another VM there I can spin up
(and would have to update to latest code) that is 64 too.

sizeof(long) is certainly going to be 32-bit. Most of NetBSD system
calls are 64-bit for file offsets and the like, however. I'm not
certain if that matters much. Pointers are certainly 32-bit here.

I'm willing to give out a NetBSD account to you if that helps :)

If I can't get my virtual machine running, I'll take you up on that
offer. Thanks!

I have production-like machines that run NetBSD-5.0.x/i386 (32-bit)
and have VMs that run:

NetBSD-5.0.x/i386
NetBSD-5.0.x/amd64
NetBSD-current/i386
NetBSD-current/amd64

In general I don't mind sharing these with you if that will help make
NetBSD more supported. If there is some sort of automated build/test
environment I could run and contribute feedback to, I would set that up
as well on all four VMs.

My goal is to get NetBSD to be a first-class Ruby citizen. :)

--Michael

=end

#5 Updated by Michael Graff about 5 years ago

=begin
Has any progress been made on this that I can test?
=end

#6 Updated by Yusuke Endoh about 5 years ago

  • Priority changed from Normal to Low
  • Target version changed from 1.9.2 to 2.0.0

=begin
I set this ticket to Low priority because there is no maintainer
for NetBSD. A patch is welcome.

--
Yusuke Endoh mame@tsg.ne.jp
=end

#7 Updated by Yui NARUSE almost 5 years ago

  • Status changed from Open to Closed

=begin
Fixed by r27890 and r27891, this also backported to 1.9.2.
=end

Also available in: Atom PDF