Project

General

Profile

Bug #3093

Openssl Extension Does Not Compile with OpenSSL 1.0

Added by cfis (Charlie Savage) over 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.2dev (2010-04-05) [i386-mswin32_100]
Backport:
[ruby-core:29256]

Description

=begin
Even with the latest patches (working against head), the openssl extension does not compile against openssl 1.0.

Patch attached.
=end


Files

openssl.patch (834 Bytes) openssl.patch cfis (Charlie Savage), 04/05/2010 12:24 PM

History

#1

Updated by mame (Yusuke Endoh) over 9 years ago

  • Assignee set to usa (Usaku NAKAMURA)

=begin
Hi,

Even with the latest patches (working against head), the openssl extension does not compile against openssl 1.0.

I cannot reproduce with gcc and Linux:

$ ./configure --prefix=... --with-openssl-dir=...
$ make && make install
$ ../ruby -ropenssl -e 'p OpenSSL::OPENSSL_VERSION'
"OpenSSL 1.0.0 29 Mar 2010"

Maybe windows-specific issue?

I don't understand your patch, but after it is applied, gcc
prints some warning, which looks dangerous:

ossl_config.c: In function ‘get_conf_section_LHASH_DOALL_ARG’:
ossl_config.c:323: warning: passing argument 1 of ‘get_conf_section_doall_arg’ from incompatible pointer type
ossl_config.c:317: note: expected ‘struct CONF_VALUE ’ but argument is of type ‘struct CONF_VALUE *
ossl_config.c:323: warning: passing argument 2 of ‘get_conf_section_doall_arg’ makes integer from pointer without a cast
ossl_config.c:317: note: expected ‘VALUE’ but argument is of type ‘VALUE *’
ossl_config.c: In function ‘ossl_config_get_sections’:
ossl_config.c:333: warning: passing argument 1 of ‘lh_doall_arg’ from incompatible pointer type

--
Yusuke Endoh mame@tsg.ne.jp
=end

#2

Updated by usa (Usaku NAKAMURA) over 9 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

=begin
This issue was solved with changeset r27458.
Charlie, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.

=end

Also available in: Atom PDF