Bug #3480

gem_prelude: activation should accomodate for '=' and gem 'gem_name', 'version'

Added by Roger Pack almost 5 years ago. Updated almost 4 years ago.

Status:Rejected
Priority:Normal
Assignee:Nobuyoshi Nakada
ruby -v:ruby 1.9.3dev (2010-06-22) [i386-mingw32] Backport:

Description

=begin
Hi all.
Noticed that currently gem_prelude.rb doesn't allow for gem activation like:

gem 'gem_name', '2.3.8'

nor

gem 'gem_name', '= 2.3.8'

The attached patch attempts to remedy this unseemly condition.
Cheers!
-r
=end

gem_prelude_accomodate.diff Magnifier (8.22 KB) Roger Pack, 06/25/2010 11:13 AM


Related issues

Related to Ruby trunk - Bug #3617: respond_to?(:gem) is false in 1.9.2-rc2 Rejected 07/26/2010

History

#1 Updated by Roger Pack almost 5 years ago

=begin
come to think of it, I'm not sure if gem_prelude accomodates for this style currently, either...

gem 'gem_name', '=2.3.8'
=end

#2 Updated by Yusuke Endoh almost 5 years ago

  • Assignee set to Nobuyoshi Nakada

=begin

=end

#3 Updated by Yusuke Endoh almost 5 years ago

  • Category set to lib
  • Target version set to 2.0.0

=begin
Hi,

I decide this issue as WONTFIX for 1.9.2.

Kernel#gem in gem_prelude.rb accepts ">", ">=", and "=" (with your
patch), but they behave the completely same. This feature does not
work correctly at all, I think. Though it may be intended behavior
since the original code was commited at r14011 by Eric himself.

Anyway, it is too late to fix this issue for 1.9.2. In addition,
I think it is no use waiting for this issue to be fixed, even if
the release is postponed. Really hopeless.

I think this issue should be fixed in 1.9.3, by the approach of
nobu's patch in #3140.

--
Yusuke Endoh mame@tsg.ne.jp
=end

#4 Updated by Roger Pack over 4 years ago

  • Status changed from Open to Rejected

=begin
moving this feature request to rubygems proper and/or the faster_rubygems gem.
=end

Also available in: Atom PDF