Project

General

Profile

Backport #3868

Segfault in 1.9.2 when using instance_eval with a Method object

Added by banister (john mair) over 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-core:32522]

Description

=begin
Code below results in segfault:

Object.new.instance_eval(&(method(:instance_variable_get)))
=end


Related issues

Is duplicate of Ruby trunk - Bug #3786: instance_execにメソッドをわたした場合の挙動Closed09/05/2010Actions
Is duplicate of Ruby trunk - Bug #3860: VM aborts when calling instance_eval on a Method converted to a procClosed09/23/2010Actions
Has duplicate Backport192 - Backport #3957: instance_exec and instance_eval crash ruby when passed '&variable' which stores a 'method(:whatever).to_param'Closed10/17/2010Actions

History

#1

Updated by kliuless (Kelvin Liu) over 8 years ago

=begin
Duplicate of #3786
=end

#2

Updated by naruse (Yui NARUSE) over 8 years ago

  • Status changed from Open to Closed

=begin

=end

Also available in: Atom PDF