Project

General

Profile

Bug #4199

make test ruby-1.9.2-p0 failed on Solaris10 x86

Added by dp (Dmitry Perfilyev) about 9 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
ruby 1.9.2p0 (2010-08-18 revision 29036) [i386-solaris2.10]
Backport:
[ruby-core:33852]

Description

=begin
#./configure
#./make
#./make test
make: Warning: Illegal dependency list for target `.DEFAULT'

sample/test.rb:assignment ......
.............
test_thread.rb .............................................bootstraptest.tmp.rb:3: [BUG] rb_register_sigaltstack. malloc error

ruby 1.9.2p0 (2010-08-18 revision 29036) [i386-solaris2.10]

-- control frame ----------
c:0007 p:---- s:0018 b:0018 l:000017 d:000017 CFUNC :new
c:0006 p:0017 s:0014 b:0014 l:00189c d:000013 BLOCK bootstraptest.tmp.rb:3
c:0005 p:---- s:0012 b:0012 l:000011 d:000011 FINISH
c:0004 p:---- s:0010 b:0010 l:000009 d:000009 CFUNC :times
c:0003 p:0015 s:0007 b:0006 l:00189c d:00048c EVAL bootstraptest.tmp.rb:3
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
c:0001 p:0000 s:0002 b:0002 l:00189c d:00189c TOP


-- Ruby level backtrace information ----------------------------------------
bootstraptest.tmp.rb:3:in <main>'
bootstraptest.tmp.rb:3:in
times'
bootstraptest.tmp.rb:3:in block in <main>'
bootstraptest.tmp.rb:3:in
new'

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

E....
#929 test_thread.rb:381:in <top (required)>': core dumped
FAIL 1/933 tests failed
*** Error code 1
The following command caused the error:
./miniruby -I./lib -I.ext/common -I./- -r./ext/purelib.rb ./tool/runruby.rb --extout=.ext -- "./bootstraptest/runner.rb" --ruby="ruby -I./lib" -q
make: Fatal error: Command failed for target
yes-btest-ruby'
=end

History

#1

Updated by naruse (Yui NARUSE) about 9 years ago

  • Priority changed from Normal to 3

=begin
Solaris is not supported.
=end

#2

Updated by yugui (Yuki Sonoda) about 9 years ago

=begin
On Sat, Dec 25, 2010 at 7:10 PM, Yui NARUSE redmine@ruby-lang.org wrote:

Solaris is not supported.

Solaris IS supported as a "best effort" platform. however, it does not
reproduce, at least on sparc platform.

--
Yuki Sonoda (Yugui)
yugui@yugui.jp
http://yugui.jp

=end

Updated by dwaller (David Waller) over 8 years ago

Still fails on ruby 1.9.2p180 on Solaris 10 x86

test_thread.rb .............................................bootstraptest.tmp.rb:3: [BUG] rb_register_sigaltstack. malloc error

ruby 1.9.2p180 (2011-02-18 revision 30909) [i386-solaris2.10]

-- control frame ----------
c:0007 p:---- s:0018 b:0018 l:000017 d:000017 CFUNC :new
c:0006 p:0017 s:0014 b:0014 l:001754 d:000013 BLOCK bootstraptest.tmp.rb:3
c:0005 p:---- s:0012 b:0012 l:000011 d:000011 FINISH
c:0004 p:---- s:0010 b:0010 l:000009 d:000009 CFUNC :times
c:0003 p:0015 s:0007 b:0006 l:001754 d:00229c EVAL bootstraptest.tmp.rb:3
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH

c:0001 p:0000 s:0002 b:0002 l:001754 d:001754 TOP

-- Ruby level backtrace information ----------------------------------------
bootstraptest.tmp.rb:3:in <main>'
bootstraptest.tmp.rb:3:in
times'
bootstraptest.tmp.rb:3:in block in <main>'
bootstraptest.tmp.rb:3:in
new'

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

E....
#930 test_thread.rb:381:in `': core dumped
FAIL 1/934 tests failed
make: *** [yes-btest-ruby] Error 1

The failing test in test_thread.rb is this one:

assert_equal 'ok', %q{
begin
10000.times { Thread.new(true) {|x| x == false } }
rescue NoMemoryError, StandardError
end
:ok
}

Presumably this test is to check that creating an excessive number of threads results in a NoMemoryError - in which case it's perfectly reasonable that the test failed because the error is clearly not handled well. But reducing the loop from 10000.times to 5000.times allows the test to pass, so for practical use of ruby 1.9.2 on Solaris 10 x86, this is good enough as no program should be pushing the number of threads in this way.

#4

Updated by naruse (Yui NARUSE) over 8 years ago

  • Status changed from Open to Feedback

Contribution is welcomed.

Updated by mame (Yusuke Endoh) about 7 years ago

  • Status changed from Feedback to Rejected

I'm thinking that too many platforms are "supported" currently with respect to the human resource.
If Solaris is really supported as a "best effort" platform, this ticket should not be left untouched so long. No effort.

So, I'm likely to reduce supported platform by making the support-level rule strict in 2.0.0.

In addition, my personal opinion is that it is not so worth to make an effort to support Solaris because of the recent situation.

Thus, I'm sorry but please make a patch yourself. It may be helpful to try trunk because sigaltstack handling was changed and improved.

--
Yusuke Endoh mame@tsg.ne.jp

Also available in: Atom PDF