Project

General

Profile

Bug #4554

test_set_errors in test_x509store.rb fails on CentOS 5.5

Added by yhara (Yutaka HARA) about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 1.9.2p180 (2011-02-18 revision 30909) [i686-linux]
Backport:
[ruby-core:35612]

Description

=begin
On CentOS 5.5, test_set_errors in test_x509store.rb fails as follows:

1.9.2 p180

1) Failure:
test_set_errors(OpenSSL::TestX509Store) [/var/home/yhara/ruby-1.9.2-p180/test/openssl/test_x509store.rb:212]:
OpenSSL::X509::StoreError expected but nothing was raised.

1.8.7 p334

1) Failure:
test_set_errors(OpenSSL::TestX509Store) [./test/openssl/test_x509store.rb:212]:
OpenSSL::X509::StoreError exception expected but none was thrown.

test_set_errors asserts that OpenSSL::X509::Store#add_crl raises an exception
when two CRLs issued by same CA are added to the store.

However, the openssl package provided by CentOS are patched not to treat this
as an error (multi-crl.patch).

=end


Related issues

Is duplicate of Ruby trunk - Bug #4122: test_x509store.rbのtest_set_errorsが失敗するClosed12/06/2010Actions

History

Updated by yhara (Yutaka HARA) about 8 years ago

Sorry, it is already reported as #4122 .

Updated by kosaki (Motohiro KOSAKI) about 8 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF