Project

General

Profile

Actions

Bug #473

closed

File.chmod does not validate the permission attribute

Added by Anonymous about 13 years ago. Updated over 10 years ago.

Status:
Rejected
Priority:
Normal
Target version:
-
ruby -v:
[ruby-core:18369]

Description

=begin
On linux systems you can write:

File.chmod( 999999, 'test.txt' )

and no exception is thrown
=end

Actions #1

Updated by nobu (Nobuyoshi Nakada) about 13 years ago

=begin
Hi,

At Sat, 23 Aug 2008 04:35:50 +0900,
Anonymous wrote in [ruby-core:18369]:

On linux systems you can write:

File.chmod( 999999, 'test.txt' )

and no exception is thrown

No reason to deny it, as long as the system allows it.

--
Nobu Nakada

=end

Actions #2

Updated by matz (Yukihiro Matsumoto) about 13 years ago

  • Status changed from Open to Rejected
  • Assignee set to matz (Yukihiro Matsumoto)

=begin
As Nobu stated, it's not a bug, and we have no reason to check numbers before invoking system calls.
=end

Actions

Also available in: Atom PDF