Project

General

Profile

Actions

Bug #5031

closed

Bug #5076: Mac OS X Lion Support

Enumerable#zip SEGFAULTs with a Range Object (Mac OS X 10.7 LION)

Added by lucasefe (Lucas Florio) almost 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
ruby 1.9.2p180 (2011-02-18 revision 30909) [x86_64-darwin11.0.0]
Backport:
[ruby-core:38085]

Description

Tested on 1.9.2-head, 1.9.2-p0 and 1.9.2-p180.

If I run this:

ruby -e '(0..255).zip(0..255)'

I get this:

-e:1: [BUG] Segmentation fault
ruby 1.9.2p290 (2011-07-09 revision 32478) [x86_64-darwin11.0.0]

-- control frame ----------
c:0007 p:---- s:0016 b:0016 l:000010 d:000010 CFUNC  :next
c:0006 p:---- s:0014 b:0014 l:000009 d:000013 IFUNC 
c:0005 p:---- s:0012 b:0012 l:000011 d:000011 CFUNC  :each
c:0004 p:---- s:0010 b:0010 l:000009 d:000009 CFUNC  :zip
c:0003 p:0014 s:0006 b:0006 l:000548 d:0025c8 EVAL   -e:1
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
c:0001 p:0000 s:0002 b:0002 l:000548 d:000548 TOP   
---------------------------
-- Ruby level backtrace information ----------------------------------------
-e:1:in `'
-e:1:in `zip'
-e:1:in `each'
-e:1:in `next'

-- C level backtrace information -------------------------------------------

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

[2]    16898 abort      ruby -e '(0..255).zip(0..255)'

But if I do:

ruby -e '((0..255).to_a).zip(0..255)'

it works ok.


Related issues 1 (0 open1 closed)

Is duplicate of Backport192 - Backport #5003: Enumerator#next segfaults in OS X Lion (10.7)Rejectedyugui (Yuki Sonoda)Actions
Actions #1

Updated by nobu (Nobuyoshi Nakada) almost 11 years ago

  • Priority changed from Normal to 3

Updated by kosaki (Motohiro KOSAKI) almost 11 years ago

  • Status changed from Open to Feedback

We haven't try the Lion beta release, but We've try the Lion production release.
(yeah, the Lion has been released yesterday)

And I'd report we confirmed your testcase work for me on Lion production release.
Can you please try latest Lion release?

Thanks.

Updated by kosaki (Motohiro KOSAKI) almost 11 years ago

  • Status changed from Feedback to Closed
  • Priority changed from 3 to Normal

Applying r32201 fixes this issue too.

Updated by naruse (Yui NARUSE) almost 11 years ago

  • Parent task set to #5076
Actions

Also available in: Atom PDF