Project

General

Profile

Bug #5420

RubyGems misleading error message for "update -l"

Added by Robert Klemme over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
ruby -v:
ruby 1.9.2p290 (2011-07-09 revision 32553) [i386-cygwin]
[ruby-core:40022]

Description

I accidentally used option -l for "update":

11:00:34 ~$ gem19 list -l facets

*** LOCAL GEMS ***

facets (2.9.1)
11:00:44 ~$ gem19 update -l
Updating installed gems
Updating facets
ERROR: While executing gem ... (Gem::GemNotFoundException)
Could not find a valid gem 'facets' (>= 0) locally or in a repository
11:01:15 ~$

The issue is with "... or in a repository": apparently the repository was not even searched because without "-l" it works:

11:01:15 ~$ gem19 update
Updating installed gems
Updating facets
Successfully installed facets-2.9.2
Gems updated: facets
Installing ri documentation for facets-2.9.2...
Installing RDoc documentation for facets-2.9.2...
11:03:56 ~$ gem19 list -l facets

*** LOCAL GEMS ***

facets (2.9.2, 2.9.1)
11:04:21 ~$

History

#1 [ruby-core:41852] Updated by Ayumu AIZAWA over 4 years ago

  • Assignee set to Eric Hodel

#2 Updated by Shyouhei Urabe over 4 years ago

  • Status changed from Open to Assigned

#3 [ruby-core:50959] Updated by Eric Hodel over 3 years ago

  • Category set to lib
  • Target version set to 2.0.0

=begin
It seems this has been fixed.

$ GEM_HOME=~/tmp/gems/ GEM_PATH= ruby20 -Ilib bin/gem update -l builder
Updating installed gems
Updating builder
Fetching: builder-3.1.4.gem (100%)
Successfully installed builder-3.1.4

=end

#4 [ruby-core:50960] Updated by Eric Hodel over 3 years ago

  • Status changed from Assigned to Closed

Also available in: Atom PDF