Project

General

Profile

Bug #6941

ID_H_TARGET no longer created after running make

Added by Martin Bosslet over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
ruby -v:
ruby 2.0.0dev (2012-08-27 trunk 36833) [x86_64-linux]
[ruby-core:47337]

Description

It seems as if the file .id.h.time (from the target ID_H_TARGET) is no longer automatically created
while running "make" on trunk.

A subsequent "make install" fails if the previous Ruby installation has already been removed because
BASE_RUBY would be needed to generate ID_H_TARGET. I used "touch .id.h.time" as a workaround,
but I guess that "make install" should be working without a Ruby executable in the PATH?

History

#1 [ruby-core:47338] Updated by Luis Lavena over 3 years ago

  • Status changed from Open to Assigned
  • Assignee set to Nobuyoshi Nakada

#2 [ruby-core:47349] Updated by Martin Bosslet over 3 years ago

Unrelated, but while debugging I noticed that line 152 [1] seems redundant because of line 535 [2].

[1] https://github.com/ruby/ruby/blob/trunk/common.mk#L152
[2] https://github.com/ruby/ruby/blob/trunk/common.mk#L535

#3 [ruby-core:47830] Updated by Nobuyoshi Nakada over 3 years ago

  • Status changed from Assigned to Closed

Now id.h doesn't depend on parse.y since r36864.

#4 [ruby-core:48003] Updated by Martin Bosslet over 3 years ago

nobu (Nobuyoshi Nakada) wrote:

Now id.h doesn't depend on parse.y since r36864.

Confirmed it's working on my end, too. Thank you!

Also available in: Atom PDF