Project

General

Profile

Actions

Bug #7221

closed

Unable to compile kgio under 1.9.3 with error: ruby-1.9.3-<plvl>/lib/ruby/1.9.1/mkmf.rb:597:in `Integer': can't convert nil into Integer (TypeError)

Added by davidderyldowney (David Deryl Downey) almost 9 years ago. Updated over 8 years ago.

Status:
Rejected
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.3p286 (2012-10-12 revision 37165) [x86_64-darwin12.2.0]
Backport:
[ruby-core:48413]

Description

The kgio gem is unable to be compiled under 1.9.3-p286. The problem is the same as reported here: https://github.com/wayneeseguin/rvm/issues/1157, specifically the same issue is seen under ruby-1.9.3-p194 as reported here at https://github.com/wayneeseguin/rvm/issues/1157#issuecomment-9045588

The actual error is:

ruby-1.9.3-p194/lib/ruby/1.9.1/mkmf.rb:597:in `Integer': can't convert nil into Integer (TypeError)

If L597 of mkmf.rb is modified to say:

return Integer((v=f.gets) ? v : 0 )

then the problem instantly goes away.

Actions

Also available in: Atom PDF